# Table of Contents

Introduction .......................................................................................................................... 1  
Why Use CORE? .................................................................................................................... 1  
Overview of the CORE Product Family .............................................................................. 2  
  - CORE Essentials ............................................................................................................. 2  
  - CORE Spectrum ............................................................................................................. 2  
  - CORE Server .................................................................................................................. 2  
  - CORE2net Web Server ................................................................................................... 2  
  - CORE University Edition .............................................................................................. 3  
Installing CORE 8 University Edition .................................................................................. 5  
Registering CORE 8 University Edition ............................................................................. 9  
Getting Started ................................................................................................................... 11  
  - Sample Solutions .......................................................................................................... 12  
  - CORE On-line Help and Documentation ....................................................................... 12  
Learning More About CORE .............................................................................................. 13  
  - CORE Features to Evaluate .......................................................................................... 13  
    - Requirements Analysis and Management .................................................................. 13  
    - Behavior Analysis ..................................................................................................... 13  
    - Architecture Analysis ............................................................................................... 13  
    - Verification and Validation ....................................................................................... 13  
    - Document and Report Generation ............................................................................ 13  
CORE Training ..................................................................................................................... 14  
Uninstalling CORE 8 University ......................................................................................... 14
Introduction
Welcome to the CORE 8 University Edition Installation Guide. This guide is intended to assist you with the steps required for getting started using one of the most robust systems engineering software tool available today:

1. installing the software,
2. obtaining an activation key,
3. starting CORE, and
4. providing additional guidance and resources available to help you use CORE.

If you have any problems or questions regarding installation of CORE 8 University Edition, contact us:

University Program Manager
+1 540.951.3322
universityprogram@vitechcorp.com

For information on systems engineering and CORE training
Visit our website at www.vitechcorp.com
+1 540.951.3322
info@vitechcorp.com

Why Use CORE?
Developing complex systems requires more than today’s office software and requirements tools can deliver. Product engineering and architecting demand a powerful support environment for life-cycle design. Whether designing a commercial product, an IT service, or a military system, satisfying diverse customers under schedule and budget constraints requires an integrated solution—a solution to synchronize requirements, analysis, and architecture; a solution to guarantee consistency and reduce risk; a solution to deliver technical and management insight into complex issues. That solution is CORE®.

The CORE Product Suite is a fully integrated, flexible approach to collaborative product design specifically developed by systems engineers for systems engineers. Supported by an experienced staff of engineering professionals with real-world knowledge of the latest approaches and proven project experience, CORE puts project success first.

Moving beyond the document-centric or view-centric packages of the past, CORE delivers a truly collaborative design-centric approach to product development. CORE provides comprehensive traceability from need definition through requirements and analysis to architecture and test. Built upon a proven approach and a central integrated design repository, CORE includes extensive function and behavior modeling notations to better understand the dynamics of your design, integrated product simulation derived directly from your models, and on-demand automatic document and view generation. With numerous views tailored to the multitude of engineering and management tasks, CORE enables your team to focus on engineering and architecting your system.

Whether your project requires formal design specifications or informal web-based documentation, strict processes or agile design explorations, top-down approaches to a new system or middle-out/bottom-up reengineering of existing systems, CORE supports your needs.
Overview of the CORE Product Family

CORE is the premier tool supporting model-based system engineering and product design including requirements analysis, behavioral analysis, architecture definition, verification, and design validation within an engineering or business process modeling project.

CORE Essentials
CORE Essentials provides individuals, small teams, and distributed users a complete model-based system engineering (MBSE) development solution ready for immediate use against a locally installed and maintained repository—yet also adds the ability to connect to a collaborative design environment as required. Enjoy a robust product that includes a rich requirements management capability, multiple modeling notations and integrated discrete-event simulation, comprehensive architecture analysis, verification and validation, and robust, on-demand documentation.

CORE Spectrum
Incorporating all of the features found in CORE Essentials, CORE Spectrum delivers comprehensive support for DoD AF 2.0 and SysML, providing a single vehicle that enables team-wide perspective and analysis and the industry-exclusive ability to deliver answers and insight in multiple formats, regardless of the input approach.

Whether working independently or as part of the collaborative enterprise team, Spectrum provides the ultimate answer in capability and flexibility.

CORE Server
Part of a large, complex, or data-rich effort? Add CORE Server as a remote repository and enable CORE Essentials and CORE Spectrum users the ability to operate offline and independently or as part of the collaborative engineering team operating together in one concurrent database. Easily maintained and time-tested with over a decade in use, CORE Server provides a secure, convenient gateway for the team to operate in unison, taking advantage of the team-wide consolidation of information.

As the engineering team centerpiece, CORE Server offers unparalleled ease of use, team-wide system-level insight, live access to the latest system changes, comprehensive analysis, and instant, thorough documentation.

CORE2net Web Server
CORE2net extends your CORE Server environment to the web. As a separately licensed component of the CORE Server, the CORE2net web server allows you to query the current information contained in the CORE systems definition repository, enabling design changes and real-time sharing of the current design state.

CORE2net enables inter- and intra-team collaboration at the enterprise level with the ability to set up appropriate access permissions; authorized team members simply log into the project website using a web browser such as Microsoft Internet Explorer®. Engineers no longer need to be co-located in order to participate in a design effort. Managers and other reviewers can access their data in familiar formats (tabular, graphical, and hyperlinked) from any location.
CORE University Edition

This University Edition of CORE is provided under special agreement for academic use only. For a more detailed evaluation, please contact Vitech Corporation at info@vitechcorp.com.

The University Edition of CORE is identical to the commercial version of CORE Spectrum with the following exceptions:

- The license will expire in alignment with the instructor’s class schedule.
- The capability to save an image file, which stores the data in a fast binary format in order to eliminate the import/export cycle, has been disabled.
- The University Edition will import/export CORE database files in binary format instead of XML format.
- The capability to maintain a recovery log has been disabled.
- Only the following subset of reports from the full version of CORE 8 are available (see the website for additional information):
  - Queries and Consistency Checks
    - Item Consistency
    - Keyword Search
    - No Descriptions Query
    - Open Issues Query
    - Recursion Query
    - Unallocated Leaf-Level Function Query
    - Unallocated Leaf-Level Requirements Query
    - Unverified Leaf-Level Requirements Query
  - Systems Engineering
    - Generic Table Output
    - HTML Report
    - IDEF0 Node Index
    - System Description Document (SDD)
  - Other
    - Database Statistics Report
    - Schema Definition Report
  - DoDAF
    - For those courses where instructors have requested it, the University Edition also includes DoDAF reports and the supporting schema.
- In addition, the capability to create and modify report scripts has been disabled.
- The Administrative Tools, which allows multiple users and groups to be created and provides other administrative functions within the CORE environment, has been disabled.
- Users are limited to a single project.
- Each class is limited to 200 elements.
- Users are limited to the number of schema extensions identified below, however, users are free to define unlimited numbers of attributes and relationships:
  - 2 additional classes
  - 4 additional relations
  - 1 additional facility
## Functional Capabilities

<table>
<thead>
<tr>
<th>Multi-user access controls</th>
<th>University License</th>
<th>Commercial License (Essentials and Spectrum)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data exchange with other tools</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Consistency Checks</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Completeness checks</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Customized tabular output</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>IDEF0 Node Index</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>System Description Document</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Database Statistics Report</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Web Page output</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Data base size</td>
<td>200 objects for each data class</td>
<td>Unlimited</td>
</tr>
<tr>
<td>Custom Reports</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Simultaneous projects</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Schema Changes</td>
<td>Limited</td>
<td>Unlimited</td>
</tr>
<tr>
<td>Architecture Frameworks (DoDAF)</td>
<td>Optional (if requested by instructor)</td>
<td>X</td>
</tr>
<tr>
<td>Government Specifications</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Model-Based Systems Engineering</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Business Process Modeling</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Comprehensive Traceability</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Behavior modeling and analysis</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Behavior model simulation</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Embedded simulation operands</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Resource modeling</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Requirements Management and Analysis</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Risk Management</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Program Management</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Verification and Validation</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Work Breakdown Structures</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Product/Component Structure</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Item and Data flow</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Traditional (Structured) and SysML Representations</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Model Integration</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Import and export of change files</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>CSV import and export capabilities</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

If you wish to use CORE for commercial or other purposes, please contact Vitech Corporation at +1.540.951.3322 or via e-mail at info@vitechcorp.com. Vitech has an official price list which provides for indefinite and evaluation licenses for CORE as well as system engineering training classes and purchased technical services.
Installing CORE 8 University Edition

The following section provides step-by-step instructions for installing the University Edition of CORE 8. If you still require assistance after following the steps in this guide, please contact Vitech Customer Support at +1.540.951.3999 or via email at support@vitechcorp.com.


2. Click on the installer to activate the InstallShield Wizard. In the InstallShield Wizard window, click Next.

3. Review the end-user license agreement which governs the use of CORE. If you accept the terms of the license agreement, click the radio button next to "I accept" and then click Next to proceed with the installation. If you do not accept the terms of the license agreement, click Cancel to end the installation.
4. Type your name in the User Name field.
5. Type your organization’s name in the Organization field.
6. If CORE should be accessible to any user who logs in to this machine, click the radio button “Anyone who uses this computer”. If CORE should only be accessible to this user account, click “Only for me”. Then click Next.

7. The installation wizard prompts you for the location to install CORE. By default, Windows applications are installed to the program files directory. You can either:
   ▪ Confirm the location and click Next.
   OR
   ▪ Click Change to select a different installation location; then click Next after selecting the alternate location.
8. Select the setup type. A **Complete** installation (recommended) will install the CORE application and documentation files. A **Custom** installation will provide you the option to exclude the documentation. Once the setup type has been selected, click **Next**.

9. CORE reports can be configured to use either US Letter or A4 paper. Select the appropriate paper size and click **Next**.
10. Click **Install** to begin the installation or click **Back** to change settings.

![Installation Wizard](image1.png)

11. After the installation routine completes, click **Finish**.

![Installation Complete](image2.png)
Registering CORE 8 University Edition

Before using CORE University Edition, you must first register and request an activation key. CORE walks you through the process below when you first launch the University Edition. The following section provides step-by-step instructions for completing the registration process. If you still require assistance after following the steps in this guide or if you encounter any problems, please contact Vitech Customer Support at +1.540.951.3999 or via email at support@vitechcorp.com.

1. From the Windows Start menu, select All Programs > CORE 8 University > CORE 8 University.

2. Select the Request Key button shown below. This will open your web browser and take you directly to the CORE University Edition registration page on the Vitech website.
3. You will be asked to provide your contact information including name and email address, your university and professor, and the password provided by your professor. Select “Request Activation Key” and you will automatically receive an activation key via email after completing registration.

4. Copy the activation key from the email into the activation key field shown step 2. Click OK.
Getting Started

1. When you first launch CORE University Edition, you will see a message similar to the one shown below indicating how many days remain before the CORE University Edition expires at the end of your course. You will periodically be reminded as the expiration date approaches. Click OK to get started.

   ![License Expiration Warning]

   Your CORE University license expires on Wednesday, June 30, 2010 (224 days from now)
   Contact Vitech Corporation at (540) 951-3322 for licensing options.
   OK

2. The project explorer below is your starting place for learning to use CORE. The Icon Reference Guide available from Help > Docs is a useful desktop tool as you start using CORE.

![Project Explorer](image)

   Welcome to CORE University Spectrum 8.0

   October 21, 2011

   Open Project
   New Project

   Did you know...

   Diagram: If you prefer to work via drag drop, you can connect two functions in the manner. First, drag the Output construct from the Constructs tab or the specific item from the Key Entities tab onto the source node. Then, drag the Control construct from the Constructs tab or the specific item from the Key Entities tab onto the second node.

   Show Tips on Startup
   Previous
   Next

   Please visit us on the web at [www.vitechcorp.com](http://www.vitechcorp.com).
   Copyright 1992-2011 Vitech Corporation. All rights reserved.
3. The University Edition is restricted and only allows you to work in one project at a time. Therefore, the Open Project and New Project links shown above are disabled in the University Edition. When you open CORE 8 University Edition, you are already in a blank project and can start adding data to the engineering repository by double-clicking on one of the elements in the left-hand list shown in the screen above. When you’re done for the session, you’ll need to save your information by exporting the data to a file using File > Export. When you want to start the next time, you'll import the data using File > Import and import the file you’d saved previously. Try this by going to File > Import to import one of the Samples described in the next section.

Sample Solutions

The Samples directory within your CORE University installation provides sample definitions of four sample projects. These files can be imported into CORE to view and manipulate. A requirements source document has been provided for some samples (i.e., GeospatialLibrarySourceDocument.doc and FastFoodSourceDocument.doc).


CORE On-line Help and Documentation

The CORE user reference guide is accessible as an online reference available from within CORE University Edition. To access context sensitive help from a specific window, simply click in the window and press the F1 function key. If you prefer to navigate by volume, flip through the index, or simply perform an electronic search, the online help will meet your needs. Also available from the CORE 8 University program group entry on the Start menu are shortcuts to documentation including:

- What’s New
- Guided Tour
- CORE System Definition Guide
- CORE Architecture Definition Guide
- CORE Icon Reference Guide
- COREsim User Guide
- MBSE Primer

Adobe’s Acrobat Reader is needed to view this documentation. You can download the latest version of Adobe Acrobat Reader free of charge at http://www.adobe.com.
Learning More About CORE

The section below describes some of the features of CORE that you may wish to explore.

**CORE Features to Evaluate**

### Requirements Analysis and Management
- Supports requirements elicitation
- Captures requirements from multiple sources
- Traces requirements to requirements and design elements
- Identifies and manages issues and risks
- Analyzes and decomposes requirements using both graphics and text
- Maintains consistency with behavior, architecture, and V&V

### Behavior Analysis
- Models system and process functionality
- Decomposes behavior hierarchically for layered development and analysis
- Provides integrated views including both functions and data to improve analysis
- Allocates functionality to physical architecture
- Provides multiple graphical representations [EFFBD, IDEF0, N2, …] of functional design
- Ensures design integrity with a single underlying model
- Executes models for dynamic verification
- Maintains consistency with requirements, architecture, and V&V

### Architecture Analysis
- Models the physical and logical architectures
- Supports multiple graphical representations of architecture decomposition and interrelationships
- Accommodates COTS systems and components
- Identifies and manages internal and external interfaces
- Characterizes the implementation of logical interfaces
- Computes numerical roll-ups across hierarchical design
- Develops alternative architectures for comparison
- Maintains consistency with requirements, behavior, and V&V

### Verification and Validation
- Develops verification requirements and plans
- Verifies architectures through dynamic execution of behavior models
- Validates requirements with behavior, physical, and verification models
- Manages all aspects of V&V from planning through specific events and results
- Maintains consistency with requirements, behavior, and architecture

### Document and Report Generation
- Generates on-demand system specifications, reports, queries, and views
- Supports standard text and graphic file formats [XML, HTML, DOC, RTF, CSV, ASCII, JPG, PNG, WMF, …]
- Provides end-to-end traceability (forward and reverse)
- Supports complete impact analysis (requirement, behavior, and architecture changes)
- Captures programmatic data including schedules and WBS
- Collaborates through stand-alone, enterprise, and web deployment
- Delivers true design integrity through a design-centric repository with view and document generators
- Supports via top-down, middle-out, and bottom-up analysis (forward and reverse engineering)
- Integrates DoDAF with system design
- Facilitates design and communication using a layered approach
CORE University Edition Installation Guide

- Incorporates a baseline schema based upon 30 years of research
- Allows customization of language and reports
- Reduces production of documentation and views to a byproduct of system design

CORE Training

Vitech offers ongoing training to help users learn more about using CORE in support of systems engineering and architecture frameworks including:

- **MBSE/CORE Basic Course** – Provides the basic concepts of the MBSE Methodology and the skills for model building in CORE
- **Scripting in CORE** – CORE can be tailored in a number of ways to suit the needs of the individual customer. This course shows how to do that using CORE’s scripting capabilities.

For more information on any of these courses, please visit our website or call Vitech at +1 540.951.3322.

Uninstalling CORE 8 University

To remove CORE 8 University from your system, select Add/Remove Programs from the Windows control panel. Select CORE 8 University from the list of applications available to uninstall and click the Add/Remove button. Follow the instructions provided by the installer to remove the application.