Logo

Celebrating 25 Years of Excellence in Systems Engineering

MBSE Webinars

MBSE, CORE, and GENESYS Training

MBSE Community

FAQ

We are confident you will begin to see benefits throughout your workgroup - and program - quickly. Below are some Frequently Asked Questions to get you started as quickly as possible.


Instructions

We provide numerous reference guides to help you get started and familiar with CORE and GENESYS. Taking advantage of this information, as well as our training options and webinars, are excellent ways to learn more about the complete capabilities of our software solutions.


CORE

When you launch CORE you will need a user name and password to log in. The default user is Administrator. The default password is admin. After logging in, you can use the Administrative Tools panel to create a unique user name and password.
CORE will not operate on a pure Mac OS platform. CORE is designed for use in a Windows environment. Although many customers have been successful installing CORE on a Mac using a Windows PC emulator, we do not have the resources to provide support for these installations.

If you encounter this error when launching CORE for the first time after installation, the Windows Data Execution Prevention security feature is preventing the CORE executable file from executing.

Following are the steps necessary to add the file to the exceptions list of the Data Execution Prevention feature.

  1. Go to Start > Control Panel > System & Maintenance > System > Advanced System Settings.
  2. Under Performance, click Settings. Then choose the Data Execution Prevention tab.
  3. Select the radio button labeled “Turn on DEP for all programs and services except those I select.”
  4. Click the Add button.
  5. Navigate to \Program Files\Vitech\CORE 9.
  6. Locate and highlight the core90.exe file. (University Program users will choose core90ac.exe.).
  7. Click the open button.
  8. Repeat to add LicenseUtil.exe.
  9. Click apply to save changes.
  10. Launch CORE. (It may be necessary to restart the computer after making this change.)

Starting in CORE 7, the option to "Save Image" in no longer present. This capability is still available. It has been renamed "Save Repository."

The use of "Save Repository" will save only the local repository. There is no need to manually save when working in an Enterprise Server repository as all changes are saved in real time as you move your cursor into another field.

We have integrated SysML with what you have come to expect from CORE. If you prefer to work from a property sheet perspective, CORE can build the SysML views. If you prefer to work from a graphical viewpoint, you can use the views to build or change your model.

CORE 9 provides the following SysML Representations:

  • Activity
  • Requirements
  • Sequence
  • Interface Block
  • Physical Block
  • Structure Block Definition
  • Classification Block Definition
  • Interface Block
  • Interface Block N2
  • Internal Block
  • Flow Internal Block
  • Package
  • Use Case
  • State Transition Diagram

The Vitech recommended solution is to schedule and run the Hot Backup script that comes with CORE. This script is located in the CORE90Server\scripts folder and can be scheduled using Windows Task Scheduler.

As part of the installation process, hot backups should have been scheduled by default. The recommended value is nightly during the work week.

The CORE services (CORE90Stone and CORE90NetLDI) must be running in order for the Hot Backup to operate correctly.

Yes! First released in CORE 9, the DOORS Connector facilitates two-way transfer of data between CORE and DOORS. For detailed information, contact our Customer Support team.

The end-user can try the default account username of 'Administrator' and password 'admin'. If this does not work, it will be necessary to contact a CORE administrator at your site. Any CORE administrator can reset another user's password.

After logging into CORE, the Welcome screen is typically displayed first.

From here you can start a new project or import an existing project.

In order to create a new project, click the New Project link on the left of the Welcome page or select New Project from the Project menu. The New Project Dialog will prompt for a project name, permission level, and base schema. Select if you want the project in the Local Repository or the Remote Repository. (Remote Repository is only available when logged into a CORE Server.) The new project will open after confirming the initial settings. The next task is to begin populating the database by capturing requirements.

To import an existing project, click File > Import.

For more detailed information, refer to the CORE Guided Tour or the Getting Started screencast collection.

From within CORE, select About CORE from the Help menu. At the bottom of the dialog box are the product name and version number. In the middle, the build number and service pack are identified.

For CORE Server, the most direct method is to navigate in Windows Explorer to the CORE90Server\scripts folder. Double click on SPReport.bat. This will send the report to the CORE90Server\logs folder. Locate the SPReport.out file in that folder and open in Notepad. A block of data at the bottom of the file will identify version, service pack, and build number.

Versioning will maintain a history of changes to attribute values as they evolve over time and allow users access to the list of versions.

For new projects, versioning is enabled by default. When you choose new project during import of an XML file from previous releases, versioning is disabled by default. When importing XML files from CORE 7,8, or 9 versioning will default to the state it was upon export. When importing an XML file into an existing project, versioning will default to the current versioning setting of that project.

A number of commands have been added to the user interface to support versioning actions and options. While there are several different menu commands and screen options, they fall into several basic actions and options:

  • Version browser – access the list of versions, enabling the user to compare versions and migrate to a past version, if desired. The version browser button is found on the left side of any attribute pane for which versioning is enabled and more than one version exists.
  • Toggle versioning – shift the state of versioning for the selected object
  • Purge versions – discard all interim attribute versions for the selected object (an element, a group of elements, a folder, or the entire project). This command maintains the baseline version and the current version while discarding all others, effectively cleaning up the database.
  • Baseline version - baseline all attribute versions for the selected object (an element, a group of elements, a folder, or the entire project). This command sets the current attribute value as the baseline version and discards all other versions.

This question is posed typically when a new computer is deployed. The License Utility in CORE can be used to decertify the current license. After installing on the new computer, the License Utility can be used to request a license. Please contact our Support Team for assistance.

Yes, CORE works on most versions of Windows. If you have concerns about your installation, please contact our support team.

GENESYS

Yes, CORE data can be imported into GENESYS. Please note that the GENESYS 3.0 schemas are based on the CORE 9 schemas. There were many changes to our schemas between CORE 8 and 9. Some projects will need to complete a data migration process in order to upgrade their schema to the CORE 9 schema, before importing it to GENESYS. This should be completed in CORE, prior to importing the data into GENESYS.
Vitech has chosen not to include the IDEF0 diagram in GENESYS. If your customer requires this view, CORE may better suit your needs.

Launch GENESYS Collaborative Edition. Below the password field, you'll see the Repository selection area. The option presented by default will be the last repository you connected to. If you've never connected to a repository other than your own, this will say "Local."

Login Screen

To select another repository, click on the down arrow to expand the view. A drop-down box appears. Drop down this box to view a list of all repositories you have previously connected to. If the repository you want to connect to is listed, then select it and click OK.

If you need to add a repository, click on the plug icon. The Manage Repository Configuration dialog will appear.

Configuration Screen

Click the plus icon to add a repository. Enter the host name or IP address and click Connect. Then click close. The repository you just added will now be selected in the Repository drop-down. Click OK.

 


Follow Us: