
 
 
 
 
 

CORE Enterprise 
Users Guide 

Client-Server Architecture for Integrated Team Environments 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

CORE:  Pro

Release 

4.0 
duct & Process Engineering Solutions 





 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

_____________________________________________________ 
Copyright © 1993-2002 Vitech Corporation.  All rights reserved. 
No part of this document may be reproduced in any form, including, but not 
limited to, photocopying, translation into another language, or storage in a data 
retrieval system, without prior written consent of Vitech Corporation. 

Restricted Rights Legend 
Use, duplication, or disclosure by the Government is subject to restrictions as set 
forth in subparagraph (c) (1) (ii) of the Rights in Technical Data and Computer 
Software clause at DFARS 252.227-7013. 

Vitech Corporation 
2070 Chain Bridge Road, Suite 320 

Vienna, Virginia 22182-2536 

CORE® is a registered trademark of Vitech Corporation. 
CORE Enterprise is a trademark of Vitech Corporation 
Other product names mentioned herein are used for identification purposes only, 
and may be trademarks of their respective companies. 



Table of Contents 

1 CORE ENTERPRISE .............................................................................................1 

CLIENT-SERVER ARCHITECTURE ....................................................................................1 
Object Repository ......................................................................................................1 
Multi-User Access......................................................................................................2 
Concurrent Updating.................................................................................................2 

2 GETTING STARTED.............................................................................................3 

ABOUT SESSION DIALOG ................................................................................................3 
THE CORE ENTERPRISE APPLICATION SERVER..............................................................4 

Starting the CORE Enterprise Application Server ....................................................4 
Stopping the CORE Enterprise Application Server...................................................4 

OTHER CORE DOCUMENTATION....................................................................................6 

3 ADMINISTRATION TOOLS ................................................................................7 

BASIC SYSTEM MANAGEMENT........................................................................................7 
NetLDI Service...........................................................................................................7 
COREStone Service ...................................................................................................8 

SCHEDULED MAINTENANCE SCRIPTS..............................................................................8 
Extent Cleaner Script.................................................................................................9 
Registry Cleaner Script..............................................................................................9 
Lock Cleaner Script ...................................................................................................9 
Object Report Script ................................................................................................10 
Hot Backup Script ....................................................................................................10 

CHANGING THE COREADMIN USER ACCOUNT ............................................................10 
RENAMING OR MOVING CORE ENTERPRISE 4.0 SERVER INSTALLATION DIRECTORIES11 
COMMIT RECORDS ........................................................................................................12 

Abort Signal .............................................................................................................12 
Lost Object Table Root ............................................................................................13 

4 BACKUP AND RECOVERY ...............................................................................14 

TRANSACTION LOGGING MODES ..................................................................................14 
BACKUP MECHANISMS..................................................................................................14 
FILE SYSTEM BACKUPS.................................................................................................16 
“HOT” BACKUPS...........................................................................................................16 
RECOVERY USING RDT FILES ......................................................................................17 
RECOVERY FROM A FILE SYSTEM BACKUP ...................................................................18 
RECOVERY FROM A HOT BACKUP .................................................................................20 

5 MANAGING USER ACCOUNTS .......................................................................23 

USER/GROUP MANAGER...............................................................................................23 
CORE USER MONITOR.................................................................................................24 

File Menu.................................................................................................................25 
Sessions Menu..........................................................................................................26 

Send Message ......................................................................................................26 



 

Request Logout ....................................................................................................26 
Force Logout........................................................................................................26 
Stop Session.........................................................................................................26 
Enable Logins ......................................................................................................27 
CORE2net Monitor..............................................................................................27 

Projects ....................................................................................................................27 
Request Project Close ..........................................................................................27 
Force Project Close..............................................................................................28 
Close All Projects ................................................................................................28 

Options Menu...........................................................................................................28 

6 OPERATIONAL DIFFERENCES.......................................................................29 

EDIT LOCKS ..................................................................................................................29 
Toggle Edit Lock (F4)..............................................................................................31 
Set Edit Lock ............................................................................................................31 
Release Edit Lock.....................................................................................................31 
Terminate Edit Lock.................................................................................................31 

ACCESSING THE SCHEMA EXTENDER ............................................................................33 
VIEW UPDATES .............................................................................................................33 
SAVING AN IMAGE ........................................................................................................33 
MANAGING PROJECTS...................................................................................................33 

Creating Projects .....................................................................................................33 
Import Settings .........................................................................................................33 
Export Settings .........................................................................................................34 

IMPORTING DATABASES................................................................................................35 
JOB MONITOR ...............................................................................................................35 

Jobs Menu ................................................................................................................36 
Server Menu.............................................................................................................36 

7 CORE2NET............................................................................................................37 

LICENSING THE CORE2NET SERVER ............................................................................37 
Generate License Request........................................................................................37 

STARTING THE CORE2NET SERVER .............................................................................38 
GIVE USERS WEB ACCESS PRIVILEGE...........................................................................39 
USING CORE2NET........................................................................................................40 

Login ........................................................................................................................40 
Homepage ................................................................................................................40 
Queries.....................................................................................................................41 
Logout ......................................................................................................................41 

A. INSTALLATION PREPARATION.......................................................................1 

SERVER INSTALLATION PREPARATION............................................................................1 
Server Installation Worksheet....................................................................................1 
CORE Users Worksheet.............................................................................................3 

B. WINDOWS NT ........................................................................................................1 

INSTALLING CORE ENTERPRISE SERVER .......................................................................1 



Launch CORE 4.0 Installer .......................................................................................1 
End-User License Agreement ....................................................................................1 
Specify Root Location Program Files........................................................................2 
Specify Location of CORE Repository.......................................................................2 
Specify Location of CORE Transaction Logs ............................................................2 
Specify Where Hot Backups Will Be Stored...............................................................2 
Specify NetLDI Port Number .....................................................................................2 
Specify Database Update Ports .................................................................................3 
Finish Running CORE Installer.................................................................................3 
Reboot ........................................................................................................................4 
Customize SYSTEM.CONF........................................................................................4 
Verify PATH Environment Variable ..........................................................................4 

CONFIGURE COREADMIN ACCOUNT .............................................................................5 
Create COREAdmin Account.....................................................................................5 
Set Directory Permissions .........................................................................................6 

FINALIZE SERVER INSTALLATION ...................................................................................6 
Create CORE Enterprise Server Services .................................................................6 
Start Task Scheduler ..................................................................................................7 
Start CORE Enterprise Server Services.....................................................................7 
Set Time Zone.............................................................................................................7 
Install Service Packs and Add-Ins .............................................................................7 

NETWORK LICENSE MANAGER INSTALLATION ...............................................................8 
Log on ........................................................................................................................8 
Launch CORE Installer .............................................................................................8 
Specify Installation Directory and Transfer Files .....................................................8 
Generate License Request..........................................................................................9 
Start Network License Manager ................................................................................9 

CORE NLM 4.3 .....................................................................................................9 
CORE NLM 2.0 ...................................................................................................10 

TROUBLESHOOTING ......................................................................................................10 
UNINSTALLING CORE ENTERPRISE 4.0 SERVER ..........................................................11 

C. WINDOWS 2000......................................................................................................1 

INSTALLING CORE ENTERPRISE SERVER .......................................................................1 
Launch CORE 4.0 Installer .......................................................................................1 
End-User License Agreement ....................................................................................1 
Specify Root Location of Program Files....................................................................2 
Specify Location of CORE Repository.......................................................................2 
Specify Location of CORE Transaction Logs ............................................................2 
Specify Where Hot Backups Will Be Stored...............................................................2 
Specify NetLDI Port Number .....................................................................................2 
Specify Database Update Ports .................................................................................3 
Finish Running CORE Installer.................................................................................3 
Reboot ........................................................................................................................4 
Customize SYSTEM.CONF........................................................................................4 
Verify PATH Environment Variable ..........................................................................4 



 

CONFIGURE COREADMIN ACCOUNT .............................................................................5 
Create COREAdmin account .....................................................................................5 
Set Directory Permissions .........................................................................................6 

FINALIZE SERVER INSTALLATION ...................................................................................6 
Create CORE Enterprise Server Services .................................................................6 
Start Task Scheduler ..................................................................................................7 
Start CORE Enterprise Server Services.....................................................................7 
Set Time Zone.............................................................................................................7 
Install Service Packs and Add-Ins .............................................................................7 

NETWORK LICENSE MANAGER INSTALLATION ...............................................................8 
Log on. .......................................................................................................................8 
Launch CORE Installer .............................................................................................8 
Specify Installation Directory and Transfer Files .....................................................8 
Generate License Request..........................................................................................9 
Start Network License Manager ................................................................................9 

CORE NLM 4.3 .....................................................................................................9 
CORE NLM 2.0 ...................................................................................................10 

TROUBLESHOOTING ......................................................................................................10 
UNINSTALLING CORE ENTERPRISE 4.0 SERVER ..........................................................11 

D. CLIENT INSTALLATION.....................................................................................1 

PREPARATION .................................................................................................................1 
Client Hardware and Operating Systems Requirements:..........................................1 
Installing CORE Enterprise Client ............................................................................1 

UNINSTALLING CORE ENTERPRISE 4.0 CLIENT .............................................................2 

E. DISASTER PREVENTION & RECOVERY........................................................1 

TURNING-ON FULL LOGGING IN CORE ENTERPRISE SERVER ........................................1 
TURNING-OFF FULL LOGGING IN CORE ENTERPRISE SERVER.......................................2 

F. UPGRADING FROM PREVIOUS VERSIONS...................................................1 

UPGRADING FROM ENTERPRISE 3.1 TO 4.0......................................................................1 
UPGRADING FROM ENTERPRISE 3.0 TO 4.0......................................................................3 
UPGRADING FROM ENTERPRISE 2.1 TO 4.0......................................................................5 

 
List of Tables 

TABLE A-1  CORE 4.0 ENTERPRISE INSTALLATION WORKSHEET................................. A-2 
TABLE A-2  CORE 4.0 USER WORKSHEET ................................................................... A-3 

 
 
 
 
 
 



 



 Chapter 1 CORE Enterprise 
 

1 

Chapter 

1 
1 CORE Enterprise 

CORE 4.0 is available in two separate, yet interoperable configurations: CORE 
Workstation (data stored in an image file on a single user’s computer) and CORE 
Enterprise (client – server architecture, data stored in a database on a server and 
accessed through Windows 98/NT/2000 client computers). 

CORE Enterprise is built upon the GemStone Object Application Server; 
individual CORE clients can now access a common server-based repository.  The 
enterprise addition provides the capability of concurrent user access as well as 
unlimited scalability.  This manual provides the information needed to use the 
CORE Enterprise Edition. 

Client-Server Architecture 
CORE Enterprise has a two-tiered object system with client server architecture.  
The server acts as an object repository.  Since the data is moved off the client 
computer and stored on the server, multiple users can access shared data.  By 
contrast, in a single-tiered system there is a single user with no sharing of objects, 
and all applications and objects for the applications reside on the computer, 
requiring the computer to be sized for the largest application. 

Object Repository 
In a traditional two-tiered system, the server uses a relational database with an 
object system on the client, making it necessary to map the table structure of data 
storage in the relational database to the objects on the client.  A programmatic 
interface is used to map the application objects to tables.  This necessitates a 
continual back and forth between the client and the server through the mapping 
interface to get data.   

CORE Enterprise uses an object two-tiered system, in which both the client and 
server “speak objects”.  Therefore the mapping of relational data on the server to 
objects on the client is eliminated, and the objects are stored in an object 
repository.  The behavior can be executed on the server, allowing the application 
to be partitioned in the way that makes the most sense for performance.  The 
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objects run on the application server, reducing the client workstation processing 
burden, and allowing your system to run faster and more efficiently.   

Multi-User Access 
The two-tiered system with client server architecture allows multiple users to 
access the database concurrently.  This simplifies the team approach to system 
engineering, while still allowing for independent analysis.  CORE Enterprise can 
operate with any number of users, working in the same project or separate 
projects.  Users cannot make changes to data unless they have elements edit 
locked; therefore, the data integrity is preserved.  Data is refreshed when users 
make changes to elements or element attributes so that each user gets a complete 
updated picture of the database before making new changes.  Access to data can 
be regulated through the permissions and read/write privileges in the User/Group 
Tool.  Therefore, users can be granted access to the specific areas of a project for 
which they are responsible. 

Concurrent Updating 
Part of the power of CORE Enterprise is the concurrent updating model.  Changes 
made by one user are reflected in ALL clients immediately.  It functions as if 
everyone were working on the same image at the same time.  For more 
information on view updates see Chapter 6, Operational Differences. 
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2 Getting Started 

CORE Enterprise runs on the GemStone Object Application Server.  The 
application server runs by various CORE processes.  Of key importance is the 
main resource coordinator and monitor process called COREStone.  To support 
the application server, CORE provides scripts to simplify your administrative 
tasks concerning the application server.  Details regarding system administration 
are provided in Chapter 3, Administration Tools.   

A few operational differences can be found in the CORE Workstation and the 
CORE Enterprise.  These differences are noted in Chapter 6 – Operational 
Differences.  For information regarding new features available in CORE, see the 
WhatsNew.txt file in the CORE 4.0 “Docs” directory provided with your 
package. 

Vitech Technical staff will assist you in the CORE Enterprise Server installation.  
Appendix A – Installation Preparation contains two worksheets that will reduce 
the time it takes for server installation.  You are expected to complete the two 
worksheets in Appendix A before scheduling the server installation with Vitech. 

About Session Dialog 
After you have successfully installed CORE Enterprise and logged on, you can 
review your access privileges and see details about your current session in CORE 
Enterprise by opening the About Session Dialog. 

You can access the About Session Dialog from the Help Menu on the CORE 
Control Panel.   

All of the information is read only, so it cannot be changed from this dialog.  The 
About Session dialog contains two panes, (see Figure 2--1).  The top pane 
contains information about your user account including your user name, full 
name, description, group membership, and user privileges.  The bottom pane 
contains information about your current session, i.e. the Server Host Name, Stone 
Name, the process identifier of the application running on the NT server (PID), 
the Session S/N (serial number of the session), the Session ID number, and the IP 
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address of your computer.  If you run into any problems, this information could 
be useful when contacting Vitech for assistance. 

 
Figure 2-1 About Session Dialog 

The CORE Enterprise Application Server 
The CORE Enterprise Server includes two Windows NT services.  In a standard 
installation, these are called COREStone and NetLDI51.  Details about these 
services and their status can be viewed in the Services Control Panel (Start > 
Settings > Control Panel > Services).  These services launch several other 
processes that will also be running on the server.   

Some of the administration tasks require that the application server be stopped 
and started.  These services may be started and stopped using either the Services 
Control Panel or one of the scripts in the scripts subdirectory. 

Starting the CORE Enterprise Application Server 
In order for users to access the CORE Enterprise Server, COREStone must be 
started.  This simple operation can be accomplished with the CORE Enterprise 
script: 

StartCOREStone.bat 
This script will start the application server.  Once COREStone is started, it will 
remain running even after the user that started it logs out.  You should run this 
command from a command line console.  If an error occurs while starting 
COREStone, you will receive a notification that the stone did not start.  If this 
happens, contact Vitech Technical Support. 

Stopping the CORE Enterprise Application Server 
Occasionally, you will be required to stop COREStone.  This is required during 
operating system backups of the CORE Enterprise Server files.  Stopping the 
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stone is a simple operation that can be accomplished with the CORE Enterprise 
script: 

StopCOREStone.bat 
This script will stop the application server.  Once COREStone is stopped, users 
will not be able to log in.  You should run this command from a command line 
console.  All users must be logged off before the command can be executed 
successfully.  Make sure that all users are logged out of GemStone before 
attempting to stop the stone.  If there is a failure reported when executing this 
command, most likely a user is still logged in.  If there are problems starting or 
stopping the services, the administrator can check the end of the appropriate log 
file for possible causes.  “COREStone.log” and “NetLDI51.log” can be found in 
the log subdirectory.  The log files for other server processes (e.g. user sessions) 
are also written in this directory.  If, for some reason, COREStone will not stop 
even after all users have logged out (preferably after exiting the CORE Enterprise 
Client application), then contact Vitech Technical Support. 

5 
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Other CORE Documentation 
In addition to this CORE Enterprise Guide, use the Vitech CORE Workstation 
User Reference Guide as a basic reference to CORE’s features and how to use 
them. 

Additional documentation on CORE Enterprise will be developed as needed to 
explain extensions to the basic tool. 

If you have any questions or need assistance, please contact us at the address and 
phone numbers below. 

 

 
2070 Chain Bridge Road, Suite 320 

Vienna, Virginia   22182-2536 
Phone: (703) 883-2270 
FAX: (703) 883-1860 

Email:  info@vtcorp.com 
Web: http://www.vtcorp.com 

 
Technical Support 
Phone: (703) 883-2270 
FAX: (703) 883-1860 

Email:  support@vtcorp.com 
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3 Administration Tools 
CORE Enterprise employs the latest industrial strength object-oriented database 
technology with the GemStone Object Application Server.  This technology 
provides a highly scaleable, disk-based multi-user system.  CORE Enterprise 
provides administration tools and scripts that allow for basic user and database 
administration of your CORE Enterprise system. 

Basic System Management 
Two services are required to run GemStone.  These are the Network Long 
Distance Interface (NetLDI51) service and the COREStone service.  They run as 
Windows NT services and are configured to start-up when the server boots 
independent of any particular login.  Details about these services and their status 
can be viewed in the Services Control Panel (Start > Settings > Control Panel > 
Services).  These services launch several other processes that will also be running 
on the server.  Users are not required to login to the NT server to operate CORE 
Enterprise.  The NetLDI and COREStone services can also be started manually 
and will continue to run after the administrator who started them logs out.  
Shutting down one or both of these services will disable access to the CORE 
Enterprise system.  Therefore, it is recommended that neither of these services be 
stopped in a production system. 

NetLDI Service 
To create the NetLDI (Network Long Distance Interface) service, run the CORE 
Enterprise script: 

createNetLDI.bat 
This script will create a Window NT service called NETLDI that is visible 
through the NT Services utility. 
Note 
This script is run during a normal CORE Enterprise Server installation to create and setup 
the NetLDI service. 

Chapter 
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COREStone Service 
The COREStone service is the main GemStone application server process that is 
required to operate the GemStone Application Server.  COREStone acts as a 
resource coordinator and monitoring process.  This service is also visible through 
the NT Services utility. 

To create the COREStone service, run the CORE Enterprise script 
createStone.bat 

This script will create a Windows NT service called COREStone that is visible 
through the NT Services utility. 
Note 
This script is run during a normal CORE Enterprise Server installation to create and setup 
the COREStone service. 

Scheduled Maintenance Scripts 
CORE Enterprise supplies scripts to provide the necessary automated scheduled 
maintenance to the CORE Enterprise Server.  These maintenance scripts are 
designed to keep your system running as smoothly as possible.  The scripts are 
named according to their function:  the Extent Cleaner Script, the Registry 
Cleaner Script, the Lock Cleaner Script, the Object Report Script, and the Hot 
Backup Script.  These scripts are scheduled to run automatically at regular 
intervals when the COREStone application server is running.  Windows NT 
provides a scheduling service that allows these scripts to be run at specified times.   

Scripts cannot run if the COREStone service is not active.  Scripts also will not 
run if the Schedule service is not active.  The first three scripts mentioned above 
are executed every time you start the COREStone service using the 
StartCOREStone.Bat script or the corresponding Start Menu command.  This 
ensures that the database is properly maintained even if the COREStone service is 
stopped regularly, such as for a file system backup.  Each of these scripts can also 
be run individually at any given time by using the corresponding Start Menu 
command or by executing the appropriate batch file in the Scripts folder.  If you 
wish to examine the current list of scheduled tasks, simply go to a command line 
and enter the following command: 

at | more 
If you wish to unschedule a particular task in the above list, go to a command 
prompt and enter the following command: 

at <id> /delete 
where <id> is the task number obtained by using the “at” command by itself.  To 
unschedule all tasks, go to a command prompt and execute the following 
command: 

at /delete 

8 
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Note that some scheduled tasks may not be related to CORE, and you should find 
out why they are there before unscheduling them.  If, after unscheduling all tasks, 
you wish to reschedule all CORE database maintenance scripts, you can execute 
the Schedule.bat file in the InstallAids subfolder of the CORE Enterprise Server 
installation folder, which is C:\COREServer by default.  To modify the schedule, 
you can edit this file before executing it.  Do not run Schedule.bat unless you 
have first removed all previously scheduled script runnings.  Otherwise, the 
scripts will be scheduled more than once at the same time, causing useless and 
unnecessary server activity. 
Note 
Output from running the scripts can be viewed in the Logs subfolder of the root CORE 
Enterprise Server program files location which was selected during installation. 

Extent Cleaner Script 
During the course of normal operation with the application server, the repository 
collects a number of objects that are no longer used by the system.  These objects 
use valuable disk space in the repository and need to be reclaimed.  The Extent 
Cleaner is a script that scans the repository for these “dead” objects, such as 
deleted elements, relationships, and even whole projects.  Once these objects have 
been identified, the application server will then automatically reclaim the space 
occupied by these objects.  This is part of the normal maintenance of the system.  
The Extent Cleaner is scheduled to each weeknight (Monday through Friday) as 
part of the automated Hot Backup procedure.  This script can also be executed 
manually at any time while the COREStone is running.   

Registry Cleaner Script 
During the normal operation of the system, when users log into the application 
server and open a project, they are automatically registered in the project/user 
registry.  This registry needs to be cleaned occasionally in order to allow the 
Extent Cleaner script to effectively complete its job.  The Registry Cleaner script 
is scheduled to run hourly to remove defunct entries from the Project User 
Registry to speed updating and notification.  An entry in the registry becomes 
defunct when the session referencing the registry terminates, i.e. when a user logs 
out or the session is stopped. 

Lock Cleaner Script 
The Lock Cleaner script is scheduled to run each weeknight (Monday through 
Friday) as part of the Hot Backup procedure.  It removes defunct locks from 
database objects.  An edit lock becomes defunct when the session referencing the 
edit lock terminates, i.e. when a user logs out or the session is stopped. 

9 
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Object Report Script 
The Object Report script appends an object audit report and a file size report to 
the end of the ObjectReport.Out file in the Logs folder.  The object audit report 
lists objects in the repository greater than 3 KB in size and reports the locations of 
corrupt objects.  The file size report shows the size of the extent file and how 
much free space exists within it. 

Hot Backup Script 
The Hot Backup script runs each weeknight (Monday through Friday).  It begins 
by invoking the same functionality as the Registry Cleaner script to remove 
defunct session records, the Lock Cleaner script to remove defunct database 
element locks, and the Extent Cleaner script to reclaim the space occupied by the 
dead and defunct objects.  This minimizes the number of objects subsequently 
backed up and the amount of disk space consumed by the backup file. 

The Hot Backup script, which can safely run while the repository is in use and 
being modified by users, proceeds to create a single backup file containing all 
information in the repository.  The file is located in the COREBackups folder, and 
its name is based on the current date and time in YYMMDDhhmm format. 

The Hot Backup script maintains one week’s worth of backup files in the 
COREBackups folder.  Each time it runs, it erases any files in that folder that are 
more than one week old (based on the file name as described above).  To preserve 
files in this folder for more than one week, you can rename them; however, it is 
preferable to archive the contents of the COREBackups folder to tape once each 
week on a regular schedule.  As your CORE Enterprise repository grows, it is 
important to ensure that sufficient free space exists in the disk partition containing 
the COREBackups folder, since the hot backup files can be quite large.  Contact 
Vitech should you need to move this folder or reduce the frequency of hot 
backups. 

Changing the COREAdmin User Account 
As part of the standard CORE Enterprise Server installation process, a user 
account with the following properties is created: 

User Name: COREAdmin 
Password: enterprise01 
Advanced User Right: Log on as a service 
Login Directory: C:\COREServer\logs 

 (where C: is the drive selected for installation of the CORE Enterprise Server 
program files) 

The COREStone and NetLDI51 services run in this account.  If the administrator 
wishes to change this account or its password, these steps should be followed: 

1. Startup information for these services must be updated in the Services 
Control Panel. 

10 
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2. The new account must be assigned full control of all the CORE Enterprise 
Server installation files and directories (the program files location, the 
extent or repository location, and the transaction logs location). 

3. The new account must also be assigned the right to log on as a service. 
4. The default login directory should be set to the COREServer\logs 

subdirectory. 

Renaming or Moving CORE Enterprise 4.0 Server 
Installation Directories 

You should not attempt to rename or move the CORE Enterprise Server 
installation directories unless necessary.  Do not rename any of the subdirectories 
within the CORE Enterprise Server program files location or move them out of 
their parent directory.  One means of moving or renaming one of the CORE 
Enterprise Server root directories is to export all the projects from CORE, 
uninstall and reinstall the CORE Enterprise Server, and import all the projects 
back into the clean installation.  (See the CORE Workstation User Reference 
Guide for instructions on exporting and importing projects.)  If this is not feasible, 
and the directories must be moved or renamed manually, then the references to 
the directories must be updated in the following manner: 

1. The %GEMSTONE% system environment variable (Start > Settings > 
Control Panel > System > Environment) should point to the root program 
files location (e.g., C:\COREServer).   

2. The %COREBackups% system environment variable should point to the 
directory where you want hot backups to be created (originally installed 
under the name COREBackups).  See the Backup and Recovery chapter 
for more information. 

3. The %CORELogs% system environment variable should point to the 
directory where you want logs to written to (originally installed under the 
name CORELogs). 

4. The %CORERepository% system environment variable should point to 
the location of the CORE Enterprise server repository (originally installed 
under the name CORERepository). 

5. The default login directory for the COREAdmin account should be 
changed to the new COREServer\logs location.  In the User Manager, 
double click on the user or select the Properties > Profile Button > Home 
Directory section and set the local path. 

6. Edit the file COREServer\data\system.conf and edit the values of the 
DBF_EXTENT_NAMES and STN_TRAN_LOG_DIRECTORIES 
parameters to reflect the new locations for the repository (extent0.dbf) and 
the transaction logs (orignally installed as CORELogs). 

7. Run the Windows NT utility REGEDIT.EXE and navigate to the 
following registry key:  

11 
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HKEY_LOCAL_MACHINE \ SOFTWARE \ GemStone \ GemStone 
Listed under the GemStone key are the 5.1.5 key, the CreatedNetldis \ 
netldi51 key, the CreatedStones \ COREStone key, and the 
RunningServers key.   

8. In the 5.1.5 key, the PathName value should point to the root program 
files location (the same as the value of the %GEMSTONE% environment 
variable specified in #1 above). 

9. In the CreatedNetldis > netldi51 key, the default Options value should 
include a reference to the location of the netldi51.log file in the logs 
subdirectory. 

10. In the CreatedStones > COREStone key, the default Options value should 
include a reference to the location of the COREStone.log file in the logs 
subdirectory and two references to the location of the system.conf file in 
the bin subdirectory. 

11. The following CORE2net registry entries should be updated to point to the 
corresponding subdirectories of the root program files location (e.g. 
C:\COREServer): 

 The path value of the HKEY_LOCAL_MACHINE \ SOFTWARE \ Vitech 
Corporation \ CORE2net Application Server \ 4.0 \ General key 

 The commonScriptDirectory, reportDirectory, and userReportDirectory values 
of the HKEY_LOCAL_MACHINE \ SOFTWARE \ Vitech Corporation \ 
CORE2net Application Server \ 4.0 \ Reports key 

 The path value of the HKEY_LOCAL_MACHINE \ SOFTWARE \ Vitech 
Corporation \ CORE2net Communication Server \ 4.0 \ General key 

 The serverRoot and userRoot values of the HKEY_LOCAL_MACHINE \ 
SOFTWARE \ Vitech Corporation \ CORE2net Communication Server \ 4.0 \ 
HTTP key 

Commit Records 
The CORE Enterprise Server maintains a record of all of the committed objects 
for each login session.  It uses this record to detect conflicts when a session 
attempts to commit a change to the database.  If there is a backlog of these records 
in the application server, processing speed deteriorates significantly.   

With the approach utilized in CORE Enterprise, a backlog of records should not 
happen.  However, if a backlog does occur, the following is an explanation of 
what will happen and what you can do. 

Abort Signal 
The CORE Enterprise Client applications are responsible for updating their view 
of the database at regular intervals.  This ensures that the backlog of records in the 
server does not build up, and that a current view of the database is maintained.  If, 
for some reason, the backlog reaches a threshold set in the system configuration 

12 
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file for the application server, a signal is automatically sent to the client that has 
least recently refreshed its view.  This is called the Abort Signal.  

The CORE Enterprise Client applications are designed to always have the latest 
view of the database and should therefore never receive an Abort Signal from the 
server.  However, it is possible that this circumstance may arise and the client will 
automatically respond to this signal by refreshing its view of the database and 
then refreshing all of the open windows to get the latest view of the database. 

Lost Object Table Root 
During the course of normal operation in CORE Enterprise, the client applications 
are responsible for maintaining an updated view of the database.  If, for some 
reason the client does not do this, the server sends an Abort Signal (described 
above) informing the client that it should update itself.  If the client fails to 
respond to the Abort Signal, the application server will forcibly abort the client 
session and then send a signal to the client called a Lost Object Table Root.  The 
client has no choice; the connection to the server terminates at this point.  No data 
will be lost if this happens.  The client machine will automatically quit out of the 
application, and then the user can login to resume a normal mode.  CORE 
Enterprise is configured to avoid this situation.  If it should occur, please contact 
Vitech Technical Support. 
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Transaction Logging Modes 
Important to this discussion is an understanding of the distinction between the 
server’s “full” and “partial” transaction logging modes.  When a CORE 
Enterprise client commits a change to the database, the change is temporarily 
written to the transaction logs before it becomes part of the database.  The 
transaction logs are stored in the directory specified for them during server 
installation, C:\CORELogs by default. 

In full logging mode, even if the server crashes before a change enters the 
database, the transaction logs capture enough information to recover the change.  
If the database becomes corrupted, the transaction logs can be reapplied to an 
earlier backup copy of the database to “roll it forward” to the current state.  Full 
logging mode is much more robust than partial logging mode. 

In partial logging mode, the transaction logs capture only enough information to 
transfer changes to the database while the server is running.  In the event of a 
server crash, a few of the most recent changes, which have not yet been written 
from the transaction logs to the database, may be lost.  If the database becomes 
corrupted, it is only possible to recover to the state of the most recent backup.  
CORE Enterprise Server performs much better in partial logging mode than in 
full logging mode. 

Because server crashes are rare and database corruption has never been observed, 
by default, CORE Enterprise Server operates in partial logging mode to take 
advantage of the performance benefits.  See Appendix E – Disaster Prevention 
and Recovery for instructions on how to switch the server between partial 
and full transaction logging modes. 

Backup Mechanisms 
Built into CORE Enterprise are several levels of redundancy to help preserve and 
protect data stored in CORE.  First, there is the database itself, also known as the 
repository or the extent, which holds all of the objects in the server.  It is 
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represented as a single file named EXTENT0.DBF and is stored in the location 
specified for it during installation, C:\CORERepository by default. 

Second, when the server is operating in full logging mode, transaction logs record 
all actions performed on the extent and thus store the information necessary to 
reconstruct transactions already committed in the event of a system loss.  These 
log files are used to recover from crashes such as those caused by a power failure, 
operating system failure or the inadvertent termination of the COREStone service.  
Transaction log files are numbered sequentially and are stored in the location 
specified for them during installation, C:\CORELogs by default.  Transaction logs 
are analogous to the recovery log maintained by CORE Workstation. 

Third, a CORE Enterprise server, by default, performs a hot backup operation 
each weeknight (Monday through Friday).  This process, which is described in 
greater detail below, effectively makes a copy of every live object in the CORE 
Enterprise repository. 

Fourth, a user can export data from the extent into a human-readable ASCII 
format called an RDT file.  It is recommended that this be done periodically, as 
the RDT format is the most stable and recoverable form of the data.  Note that 
each project in the CORE Enterprise repository is exported to a separate RDT file.  
The RDT files contain data only.  Any underlying schema changes must be 
exported separately to an SCH file.  RDT and SCH files can also be used to move 
data into CORE Workstation.  It is best to give RDT and SCH files the same name 
as the projects from which they were exported. 

In the event of a power outage or other sudden failure that leaves the hardware 
and file system intact, no special recovery steps are necessary.  Simply reboot the 
server, and the extent will come back online.  If the server was operating in full 
logging mode, any data at the end of the transaction logs that had not yet been 
written to the extent will be automatically loaded and saved.  If the server was 
operating in partial logging mode, the last few changes may be lost. 

In the event that the transaction logs are damaged but the extent file remains 
intact, you can also simply reboot the system, and only a very small amount of 
data will be lost—that which was written to the transaction logs but did not make 
it into the extent.  At this point, however, you will wish to make a full backup of 
the extent using one of the methods described below.  If you are using full 
transaction logging mode, this will ensure that it is still possible to recover all 
data committed henceforward, should another catastrophe occur. 

In the event that the extent is damaged but the transaction logs remain intact, and 
if the server was operating in full transaction logging mode, then it is possible to 
recover from an older backup copy of the extent by replaying appropriate 
transaction logs to bring it up to date. 

In the event that both the extent file and the transaction logs are damaged, it will 
only be possible to recover data to the point of the latest extent and full 
transaction log set or RDT file set that has been backed up to another location.  

15 
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The extent backup can be either a file system backup or a hot backup, as 
described below. 

If your server is operating in full transaction logging mode, you should back up 
your extent often enough so that all transaction logs created or modified since the 
backup will fit in the transaction log directory at the same time.  You can remove 
older transaction logs only if you maintain archives of all transaction logs created 
or modified since the last extent backup.  If your server is operating in partial 
transaction logging mode, the default, you should back up your extent even more 
often, because, in the event of database corruption, you will only be able to 
recover to that point.  By default, CORE Enterprise performs a hot backup 
operation, as described below, every weeknight (Monday through Friday). 

File System Backups 
 
Note 
The CORE Enterprise extent file cannot be backed up using file system tools while the 
CORE Enterprise Server software is active, even if your backup software supports backing 
up files that are in use! 

 
To back up the extent using file system backup software such as ArcServe, 
Norton Backup, etc., you must first stop the COREStone service using the Stop 
COREStone command on the Start menu.  Once the file system backup is 
complete, you can restart the service. 

On the other hand, the transaction logs can be backed up safely using file system 
tools while the CORE Enterprise Server software is in operation as long as the 
backup software supports backing up open files.  If your server is operating in 
partial logging mode, the transaction logs cannot be used for recovery and should 
not be backed up. 

You are encouraged to establish and diligently follow a disciplined policy for file 
system backup. 
Note 
When backing up extents and transaction logs, please ensure that their names and last-
modified timestamps are preserved.  This information will be required to use these 
backups.  You also need to know which transaction logs were used with which extents. 

“Hot” Backups 
A hot backup is a backup of the CORE Enterprise extent while the CORE 
Enterprise Server software is running.  As stated above, a hot backup cannot be 
performed using standard backup software.  However, you can make a hot backup 
of the extent using a special tool built into CORE Enterprise Server.  This 
mechanism has two advantages over a file system backup: 

1. You can make a hot backup of your database while users are logged into it 
and modifying it. 
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2. When you restore from a backup made in this way, the extent is 
compacted and space used by defunct objects is reclaimed. 

The CORE Enterprise server automatically makes a hot backup each weeknight 
(Monday through Friday).  You can make a hot backup at any time by following 
these steps: 

1. Run the Hot Backup script by double-clicking HotBackup.Bat in the 
Scripts directory or by clicking on the corresponding Start menu 
command. 

2. The backup will be stored as a single file in the directory selected for hot 
backups during server installation, C:\COREBackups by default.  To view 
or modify the location under Windows NT, go to Start > Settings > 
Control Panel > System > Environment and inspect the value of the 
“COREBackups” variable.  (Under Windows 2000, go to Start > Settings 
> Control Panel > System > Advanced > Environment Variables.)  The 
backup filename is based on the current date and time in 
YYMMDDhhmm format.  The Hot Backup script maintains one week’s 
worth of backup files in the COREBackups folder.  Each time it runs, it 
erases any files in that folder that are more than one week old (based on 
the file name as described above).  As your CORE Enterprise repository 
grows, it is important to ensure that sufficient free space exists in the disk 
partition containing the COREBackups folder, since the hot backup files 
can be quite large.  Contact Vitech should you need to move this folder or 
reduce the frequency of hot backups. 

3. Verify that the backup was successfully completed by looking at the 
bottom of the HotBackup.Out file, in the COREServer\logs directory.  The 
result before the “output pop” should be “true”. 

4. If the hot backup location mentioned above is not already on an archival 
medium, the hot backup of the extent should then be archived using 
standard backup tools. 

5. If your server is operating in full logging mode, also make a file system 
backup of the transaction logs. 

6. You may wish to remove old backups from the hot backup location to free 
storage space. 

Recovery Using RDT Files 
An RDT file captures a snapshot of a project in the CORE Enterprise repository—
the state of that project at a given moment in time.  A set of RDT files (one per 
project) can capture the state of the entire repository.  To restore the repository to 
that state, follow these steps: 

1. Using one of the techniques described above, back up the current state of 
the repository, in case you should later wish to return to it. 

17 
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2. Make sure all users are logged out.  Then stop the COREStone service 
using the menu command for that purpose on the server. 

Caution 
When performing the following step, all data in the repository at that time will be lost. 

3. Remove or erase the repository EXTENT0.DBF from the extent location 
determined during server installation, C:\CORERepository by default 

4. Copy the file ExtentForImport.DBF from the COREServer\backup 
directory into the above location (e.g., C:\CORERepository) and rename it 
EXTENT0.DBF. 

5. You must start a fresh set of transaction logs to go with the new 
repository.  Remove all existing transaction logs from the directory 
specified for them during server installation, C:\CORELogs by default. 

6. Restart the COREStone service using the menu command for that purpose 
on the server. 

7. Set the new repository to the correct time zone.  To do this, look in the 
COREServer\scripts directory and double click on TimeZone.Bat.  (The 
file TimeZone.Scrpt should have been edited during server installation to 
reflect the local time zone.) 

8. Start a CORE Enterprise client that has been configured to use this server 
and has access to the RDT files to be restored.  The client can run 
anywhere on the network, but for this type of bulk operation, you will 
almost certainly want to run it on the server machine itself for 
performance reasons. 

9. Use the client to create a project for each RDT file to be imported.  
Ideally, each project should be named the same as the project from which 
the corresponding RDT file was exported. 

10. If an RDT file requires any schema changes, then first use the client to 
import the corresponding SCH file into the appropriate project. 

11. Finally, use the client to import the RDT files into the proper projects. 

Recovery from a File System Backup 
To recover your extent from a file system backup (e.g., an archival copy on tape), 
follow these steps. 

1. Using one of the techniques described above, back up the current state of 
the repository, in case you should later wish to return to it. 

2. Make sure all users are logged out.  Then stop the COREStone service 
using the menu command for that purpose on the server. 

 
Caution 
When performing the following step, all data in the repository at that time will be lost. 
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3. Remove or erase the repository EXTENT0.DBF from the extent location 
determined during server installation, C:\CORERepository by default 

4. If your server is operating in partial logging mode, then you must delete 
all transaction logs from the transaction log directory specified during 
installation, C:\CORELogs by default. 

Note 
If your server is operating in full logging mode but the extent you are restoring is not an 
earlier version of the extent you just removed, then you must also remove all transaction 
logs associated with the removed extent.  These transaction logs cannot be used with the 
extent you wish to restore. 

 
Note 
If your server is operating in full logging mode and you are restoring an earlier version of 
the same extent, then you should leave the existing transaction logs in the transaction log 
directory, although any that are older than the backup extent will not be relevant. 

5. Obtain an archival copy of the extent to be restored. 
6. You can “replay” transaction logs made in full logging mode to “roll 

forward” the backup extent and bring it up to date.  If you wish to do this, 
then also obtain archival copies of any transaction logs made in full 
logging mode that were subsequently used with that extent—all those 
created and/or modified after the extent backup was made.  This may 
include the last transaction log created before the backup if that 
transaction log continued to be modified after the backup was made.  If 
the sequence of transaction logs is broken, you will only be able to restore 
data through the last contiguous log file.  For example, if you obtain an 
extent backup made a month ago, the transaction logs you need might be 
spread across the same backup tape as the extent and the subsequent four 
weekly backup tapes.  Note that some or all of the transaction logs you 
need might actually still be in the transaction log directory. 

Note 
You cannot replay transaction logs made by the server in partial logging mode, which is 
the default operating mode. 

7. Use the backup tool that created the archival copy of the extent to restore 
it into the above extent location, and ensure that it is named 
EXTENT0.DBF. 

8. Note the date and time at which the restored extent was last modified.  
Now restore into the above transaction log location all transaction logs 
made in full logging mode that were used with the restored extent after it 
was backed up.  This may include the last transaction log created before 
the backup.  Some or all of the required transaction logs may already be in 
the transaction log directory. 

 
Note 
Do not restore transaction logs made by the server in partial logging mode. 
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9. Execute the script RestoreFileSystemBackup.Bat in the 
COREServer\scripts directory.  This will restart the server in restore mode 
and, if possible, will replay the transaction logs to bring the old extent up 
to date. 

10. The results are stored in a file named RestoreFileSystemBackup.Out 
within the COREServer\logs directory.  Ensure that both statements in this 
file gave a result of “true”. 

12. If the recovery was successful, you are now ready for users to log in and 
resume normal operations.  To ensure that future recoveries are possible 
should another disaster occur, please make a backup of the present state of 
your extent as soon as possible. 

Recovery from a Hot Backup 
To recover your extent from a hot backup, follow these steps: 

1. Using one of the techniques described above, back up the current state of 
the repository, in case you should later wish to return to it. 

2. Make sure all users are logged out.  Then stop the COREStone service 
using the menu command for that purpose on the server. 

Caution 
When performing the following step, all data in the repository at that time will be lost. 

3. Remove or erase the repository EXTENT0.DBF from the extent location 
determined during server installation, C:\CORERepository by default 

4. If your server is operating in partial logging mode, then you must delete 
all transaction logs from the transaction log directory specified during 
installation, C:\CORELogs by default. 

Note 
If your server is operating in full logging mode but the extent you are restoring is not an 
earlier version of the extent you just removed, then you must also remove all transaction 
logs associated with the removed extent.  These transaction logs cannot be used with the 
extent you wish to restore. 

 
Note 
If your server is operating in full logging mode and you are restoring an earlier version of 
the same extent, then you should leave the existing transaction logs in the transaction log 
directory, although any that are older than the backup extent will not be relevant. 

5. Obtain an archival copy of the hot backup file to be restored.  Unless you 
have taken explicit steps to archive and remove them, hot backup files 
from the past week can be found in the location specified for them during 
installation, C:\COREBackups by default.  To view the location under 
Windows NT, go to Start > Settings > Control Panel > System > 
Environment and inspect the value of the “COREBackups” variable.  
(Under Windows 2000, go to Start > Settings > Control Panel > System > 

20 



Chapter 4 Backup and Recovery 
 

Advanced > Environment Variables.)  Backup filenames are based on 
their creation date and time in YYMMDDhhmm format. 

6. You can “replay” transaction logs made in full logging mode to “roll 
forward” the restored extent and bring it up to date.  If you wish to do this, 
then also obtain archival copies of any transaction logs made in full 
logging mode that were subsequently used with the extent that generated 
the hot backup file—all those created and/or modified after the hot backup 
was made.  This may include the last transaction log created before the 
backup if that transaction log continued to be modified after the backup 
was made.  If the sequence of transaction logs is broken, you will only be 
able to restore data through the last contiguous log file.  For example, if 
you obtain a hot backup file made a month ago, the transaction logs you 
need might be spread across the same backup tape as the extent and the 
subsequent four weekly backup tapes.  Note that some or all of the 
transaction logs you need might actually still be in the transaction log 
directory. 

Note 
You cannot replay transaction logs made by the server in partial logging mode, which is 
the default operating mode. 

7. Copy the hot backup file to be restored into the COREBackups directory.  
This is the same directory where it was originally created, so unless you 
explicitly removed it, no action is required here.  To view or modify the 
location under Windows NT, go to Start > Settings > Control Panel > 
System > Environment and inspect the value of the “COREBackups” 
variable.  (Under Windows 2000, go to Start > Settings > Control Panel 
> System > Advanced > Environment Variables.) 

8. Rename the hot backup file you wish to restore EXTENT0.DBF. 
9. Note the date and time at which the hot backup file was last modified.  

Now restore into the above transaction log location all transaction logs 
made in full logging mode that were used with the restored extent after it 
was backed up.  This may include the last transaction log created before 
the backup.  Some or all of the required transaction logs may already be in 
the transaction log directory. 

Note 
Do not restore transaction logs made by the server in partial logging mode. 

10. Obtain a copy of a clean extent file.  One is stored in the BACKUP 
subdirectory of the CORE Enterprise Server root program files location, 
C:\COREServer\backup by default.  It has a file size of 8,388,608 bytes.  
Copy this clean extent file into the extent location determined during 
server installation—the same one from which the existing extent file was 
removed in step (3). 

11. If the server is operating in partial logging mode, the default, execute the 
script RestoreWithPartialLogging.Bat in the COREServer\scripts 
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directory.  If the server is operating in full logging mode, execute 
RestoreHotBackup.Bat. 

12. The results are stored in a file named RestoreWithPartialLogging.Out or 
RestoreHotBackup.Out (depending on the script used in the previous step) 
within the COREServer\logs directory.  Ensure that all statements in this 
file returned successful results. 

If the recovery was successful, you are now ready for users to log in and resume 
normal operations.  To ensure that future recoveries are possible should another 
disaster occur, please make a backup of the present state of your extent as soon as 
possible. 
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Users with administration privileges can access the User/Group Manager and 
have full privileges in the CORE User Monitor through the CORE Control Panel 
> Utilities > User/Group Tool command (and User Monitor command) shown in 
Figure 5-1.  These tools regulate user access to the system.  In the event of a 
problem, the CORE User Monitor aids the administrator in determining which 
users are still logged on, and whether an account is still active. 

 
Figure 5-1  CORE Control Panel Utilities Menu 

User/Group Manager 
The User/Group Manager (Figure 5-2) is used to create, delete, and set the 
attributes of user accounts in terms of access and permissions.  (Refer to Chapters 
4 and 24 of the CORE Workstation User Reference Guide.)  The User/Group 
Manager functions the same as in the CORE Workstation version.  It allows an 
administrator to set the user privileges and group permissions.  However there is 
one difference to note in the CORE Enterprise version.  It is possible for an 
administrator to delete a user using the User/Group Manager tool while that user 
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is logged in.  Although removed from the CORE registry, the user can continue 
working in CORE until logging out.  After logout, the user will not be able to log 
in again.  If necessary, the administrator can delete the user from the registry and 
then proceed to stop the session using the CORE User Monitor tool.  This will 
effectively terminate the user session. 

 
Figure 5-2  User/Group Manager Window 

CORE User Monitor 
The CORE User Monitor window displays logged-in users and what projects they 
have open (see Figure 5-3).  All users can access the CORE User Monitor 
window and have the ability to send messages or request other users to close a 
project.  The administrator can send users an instant message, request a user to 
close a project, request a user to logout, forcibly close a user out of a project, or 
forcibly close the user’s session altogether.  The User Monitor Tool consists of 
four areas: pull-down menus (File, Sessions, Project, and Options), User Monitor 
toolbar, Active Users pane, and Open Projects pane.  The active user list contains 
the following items: 

 User name, 
 S/N:  Serial number of the session,  
 PID: the process identifier of the client application running on the NT 

server,  
 IP address of the user’s computer, 
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 Oldest CR: the oldest commit record i.e. notification of activity on the 
server.   

The Administrator in case of problems can use these pieces of information.  For 
example, a client that is no longer responding to the server will appear with “true” 
in the Oldest CR column.  The IP address and/or the User Name can identify a 
session.  The process identifier can be used to determine how much memory a 
particular client process is using on the server.   

Figure 5-3  CORE User Monitor Window 

File Menu 

 
The File pull-down menu commands are discussed in the CORE Workstation 
User Reference Guide. 
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Sessions Menu 
A session refers to the connection to the application server for a particular user.  
The Sessions menu illustrated in Figure 5-4 includes commands to regulate user 
activity including Send Message, Request Logout, Force Logout, Stop Session, 
Logout All Sessions, Enable Logins, and CORE2net Monitor. 

 
Figure 5-4  CORE User Monitor Sessions Pull-down Menu 

Send Message 
The Send Message command sends an instant message to a user.  The message 
command can be used for a variety of purposes including providing server 
information or coordinating activities in projects. 

Request Logout 
The Request Logout command sends a message to the selected user to logout.  
(The user may choose to ignore the request.) 

Force Logout 
The Force Logout command logs a user out of CORE.  The CORE Login screen 
appears for the user to exit CORE or log back in.  This feature is only available to 
users with administrator privileges.  

Stop Session 
The Stop Session command immediately ends a user’s CORE session.  This 
differs from the Force Logout command in that it not only logs the user out of 
CORE, but also forces the client application of the selected user(s) to quit.  
Occasionally, a session will stop responding to the system.  These are called 
“hung” sessions.  Such sessions will not respond to the Force Logout command, 
and the Stop Session command must be used to end the session.  There may also 
be cases in which the session of an administrative, non-CORE user (i.e. GcUser) 
needs to be stopped, for example, if the administrator wants to suspend all logins 
during extended periods of administration.  The Stop Session command should be 
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used to stop these sessions. This feature is only available to users with 
administrator privileges. 

Enable Logins 
The Enable Logins command toggles to either allows authorized users to log in to 
CORE (when checked) or prevent any users from logging in to CORE (when 
unchecked).  This command is used (Enable Logins – unchecked) during periods 
of extended administration such as modifying multiple schemas or performing 
bulk data imports to prevent users from logging in to CORE while such tasks are 
being performed.  Once all tasks are complete, the Enable Logins – checked 
command is used to allow authorized users the ability to log back in to CORE.  
This feature is only available to users with administrator privileges. 

CORE2net Monitor 
This command opens a window that allows a user to monitor and administer the 
CORE2net features.  These features provide CORE database access via web 
browsers.  This feature is only available to users with administrator privileges.  
See chapter 7 for more information on CORE2net. 

Projects 
The Project menu shown in Figure 5-5 includes commands to regulate user 
activity in a specific project or all projects including Request Project Close, Force 
Project Close, and Close All Projects. 

 
Figure 5-5  CORE User Monitor Project Pull-down Menu 

There are several operations in CORE Enterprise that require that only one user 
be logged in to a project at any given time.  These operations include switching to 
schema mode, erasing the database and erasing the database history.  The 
following commands can be used to ensure that only one user is present in a 
project during these events.  These commands do not end the user’s session, but 
do closeout all windows for the specified project(s). 

Request Project Close 
The Request Project Close command sends a message to a user asking them to 
close a particular project, (which the user can choose to ignore). 
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Force Project Close 
The Force Project Close command closes a user out of a project, but does not end 
their CORE session altogether.  This feature is only available to users with 
administrator privileges. 

Close All Projects 
The Close All Projects command closes all of the projects open for the selected 
user(s).  If more than one user is selected in the Active Users list (by clicking and 
dragging with the left mouse button), a combined list of all of the projects those 
users have open appears in the Open Projects window.  Selecting the Close All 
command will close all of those projects. This feature is only available to users 
with administrator privileges. 

Options Menu 

 
The Options pull-down menu commands are discussed in the CORE Workstation 
User Reference Guide. 
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In general, CORE Enterprise users can follow the basic CORE Workstation User 
Reference Guide except for a few differences noted in this addendum.  The areas 
of change include edit locks, accessing the Schema Extender, automatic view 
updates, saving an image, and deleting projects.   

Edit Locks 
Having multiple users in a system requires some control on who is changing data 
at a single point in time.  If two people try to edit the same data at the same time, 
one change will happen and the other may not, or the users may not be basing 
their edits upon the most current state of the database.  To solve this problem, 
CORE requires that you have an element edit locked in order to make changes to 
it.  When you create an element, it is automatically edit locked to you until you 
release it.  No one else can edit the attributes of that element until you release 
your edit lock. 

Figure 6-1 highlights three areas: the Edit Lock the Selected Elements icon, the 
Name, Number, and Description area, and the Status area.  When Edit Lock is not 
set, the areas are grayed-out – not editable. 

Figure 6-2 shows the same three areas with Edit Lock set.  The element 
“Deficiencies” in Figure 6-2 was edit-locked on 10/13/2000 by the user 
Administrator. 

There are several different ways in which elements can be edit locked.  The first 
way, mentioned above, occurs automatically when you create a new element.  
When you import a database into a project, all of the elements in the project are 
automatically edit locked to the user who imported them, since an import is 
similar to a batch creation process.   
Note 
All user locks are automatically released when the user logs out of CORE. 

Figure 6-3 shows the Database Editor > Locks pull-down menu commands: 
Toggle Edit Lock, Set Edit Lock, Release Edit Lock, and Terminate Edit Lock. 
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Figure 6-1  Edit Lock Status “Cleared” Window 

 

 
Figure 6-2  Edit Lock Status “Set” Window 
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Figure 6-3  Locks Pull-down Menu 

Toggle Edit Lock (F4) 
The command Toggle Edit Lock sets the edit lock if it is not already set, and 
releases the edit lock if it is set. 

Set Edit Lock 
The command Set Edit Lock turns the edit lock on for the element selected, 
allowing you to edit the element (and preventing other users from doing so). 

Release Edit Lock 
The command Release Edit Lock turns your edit lock off so that another user can 
lock and edit the element. 

Terminate Edit Lock 
If you are logged into a CORE user account, which has administrative privileges, 
this command enables you to break an edit lock held by another user.  This should 
be used with caution and only when necessary, as it may result in a loss data by 
the other user (at most, any changes to the field where the user was typing when 
you broke the lock).  The CORE User Monitor tool allows you to forward a 
message to the user to notify them of the impending action. 
Changes to an element, its attributes, or its structures (i.e. FFBDs) cannot be 
made without first locking the element.  This includes renaming or deleting an 
element.  However, neither the addition/removal of targets nor the editing of 
relationship attributes requires an edit lock. 
Because of the necessity of locking/unlocking elements the Toggle Edit Lock, Set 
Edit Lock, Release Edit Lock, and Terminate Edit Lock commands have been 
added to many views in CORE.  This applies to diagrams as well.  For example, 
to open a diagram on an element and make any modifications to the diagram, any 
elements within the diagram that you wish to edit must be edit locked by you.  
Right clicking on an element in a diagram to open the shortcut menu and setting 
the edit lock on the element can accomplish this.  
Multiple elements can be edit locked on a diagram by highlighting a selection of 
elements by selecting the first element, then holding the Shift key while selecting 
additional elements.  Once all elements are selected, use the Locks pull-down 
menu to Toggle Edit Lock, Set Edit Lock, Release Edit Lock, or Terminate Edit 
Lock.  See Figure 6-4. 
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Figure 6-4  Multiple Element Select Window 

 

 
Figure 6-5  Text View Edit Lock Menu 

Elements can be locked in a text view.  The Edit lock menu on the text view 
(shown in Figure 6-5) contains the same commands as that of the element menu 
on the Database Browser and Editor (Figure 6-3). 
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Accessing the Schema Extender 
In CORE Enterprise, only one user (with schema privileges) can access the 
schema extender for a given project at a time.  All other users must be logged out 
of the project.  In order to see who is logged in to a project, a user can access the 
CORE User Monitor and view current user sessions and the projects they have 
open.  Users are registered in the user monitor after they log in and open a project.  
They become unregistered when they close the project or exit the application.   

View Updates 
View updates are an essential part of CORE.  The views remain consistent with 
each change to the data and reflect the true state of the database.  View updates 
are received from users as soon as a change is made, (e.g., modifying the number 
for an element will update an open text view of the element, update a diagram on 
which the element is displayed, etc.).  Each client periodically (every few 
seconds) checks for pending updates and refreshes automatically as appropriate. 

Saving an Image 
You may notice that CORE Enterprise does not have an option to save an image.  
That is because with every action that a user makes, a commit is sent immediately 
to the database.  Therefore, even if an image crashes, all data is still intact.  
Because of this, CORE Enterprise also does not require a Recovery Log. 

Managing Projects 
As in the CORE Workstation version, users must have project privileges to create 
a new project.  This can be done from the Project Editor.  Projects can also be 
deleted using the project editor.  Of special note in CORE Enterprise, in order to 
delete a project from a system, no users may be logged into that project, including 
the user who is deleting the project. 

Creating Projects 
Creating a project will happen much quicker on the server than on a client 
machine.  Therefore, it is recommended that projects be created from a client 
running on the server (or a client machine with a very high bandwidth network 
connection to the server), especially if you are working concurrently with other 
users, since their processing speed will be affected. 

Import Settings 
The Import Settings command allows you to load a settings file previously 
exported from CORE into your project.  This allows the user to establish all of the 
desired settings (including sort block definitions, hierarchy definitions, and user 
preferences) and either use them in new projects or share them with other sites.  

33 



Chapter 6 Operational Differences  

 
Figure 6-6  Import Settings Complete Window 

Export Settings 
Remember that when you export settings, the following dialog appears (Figure 
6-7) to choose the categories of settings to include in the file.  One or more 
categories can be selected. 

 
Figure 6-7  Export Settings Dialog Window 

In order to import the settings file, CORE presents you with a standard dialog to 
select an stg (settings) file to open.  All settings in the stg file are then integrated 
into the project.   

 
Figure 6-8  Export Settings Complete Window 

In CORE Enterprise, if you are importing a “settings” file that contains sort block 
definitions or hierarchy definitions, you must be logged in as Administrator, and 
be the only person logged in to the project.  Otherwise, you will receive a 
message saying that you do not have sufficient privileges to import sort blocks or 
hierarchy definitions.  However, the user preferences in the file will still be 
imported.  If the file contains only user preferences, you can import it any time. 
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Note 
Where appropriate, CORE will merge settings upon import (e.g., hierarchy definitions and 
sort block definitions).  However, in most cases, the values in the exported settings file will 
override any existing settings upon import.  Therefore, if you are sharing your settings with 
a team member, ensure that you export only those settings that are desired. 

 

Importing Databases 
Under CORE Enterprise, database imports are automatically submitted to the 
server to be performed remotely.  When a database file has been selected for 
import, a job will be submitted to the server.  A notification message will be 
displayed when the job is complete. 

Job Monitor 

 
Figure 6-9  Job Monitor 

The Job Monitor window displays the list of import jobs at the Job Server.  The 
Job Monitor is automatically opened within the Enterprise Client when a database 
import is started.  The monitor can also be opened via the Utilities > Job Monitor 
command within the CORE Control Panel.  When opened by a standard CORE 
user, the Job Monitor displays only the jobs owned by that user account. When 
opened by an administrator account, all jobs from all users are displayed. The 
Administrator account has full control over all jobs. The list can include jobs in 
one of three states:  

1. Waiting – The job is waiting to be executed. 
2. Running – The job is currently executing. 
3. Finished – The job has finished execution. 

The following describes the columns of the Job Monitor list: 
 User – The account name of the user who submitted the job. 
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 Description – A prefix indicating the job type and the path to the file 
being imported. 
 Project – The target project of the import. 
 Status – The state of the job (Waiting, Running, or Finished). 
 Submitted – The date and time at which the job was submitted. 
 Started – The date and time at which the server started running the job. 
 Completed – The date and time at which the job was completed. 
 Owner SN – The session serial number of the process that submitted the 

job. 
 Operator SN – The session serial number of the process running the job. 

Jobs Menu 
The following commands are available on the Job Monitor’s “Job” menu: 

 Review Conflict File – Allows the user to view the conflict file resulting 
from conflicts encountered during the import job.  As jobs are performed 
on the server, conflict files are created on the server if necessary.  When 
this command is selected, the conflict file is copied to the directory in 
which the import file resides on the client machine.  A copy of the conflict 
file will remain in the Enterprise Server’s temp directory 
(C:\COREServer\temp by default) until the job is purged from the server 
or the server is restarted. 
 Purge Waiting Job – Removes the selected job from the Job Server’s 

waiting queue. 
 Purge Finished Job – Removes the selected job from the Job Server’s 

finished queue. 
 Purge Defunct Job – Allows the user to remove jobs that finish 

abnormally. 

Server Menu 
The following command is available on the Job Monitor’s “Server” menu: 

 Start Job Server – Allows an administrator account to start/stop the Job 
Server.  The Job Server must be running to permit all CORE Enterprise 
database imports.  The Job Server is automatically started after the CORE 
Enterprise Server is installed.
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A separately licensed component of the CORE Enterprise Server, CORE2net 
functions as a Web server providing access to information and models contained 
in the CORE database.  CORE2net users require only appropriate access 
permissions and an Internet browser.  CORE2net is a “CORE viewer” that does 
not require any special software to be installed on the user’s computer. 

Licensing the CORE2net Server 
Ensure that the CORE Enterprise Server has been properly installed and 
configured.  See Appendix B (Windows NT) or Appendix C (Windows 2000) for 
more information on installing the CORE Enterprise Server, or see Appendix F if 
you are upgrading from a previous version. 

Generate License Request 
Note 
Only run the License Request Editor once.  All CORE licenses including CORELIC2.DAT 
and REGISTRY.DBX files you receive from Vitech will be invalidated if you generate a 
subsequent license request on the same computer.  If you have previously generated a 
request on the computer running the CORE Enterprise Server, send in the same request 
(again) along with the information specified by number 6 below. 

1. Open Start > Programs > CORE Enterprise 4.0 Server > Utilities > 
License Request.  In the License Request Editor, 

2. Choose the File > Generate menu command. 
3. Enter your name or customer name in the User Information dialog.   
4. Enter the serial number found on the back of the CORE CD case and click 

on the OK button. 
5. Choose the File > Save As menu command in the License Request Editor 

and specify a file location. 
6. Send an email to support@vtcorp.com with the following information. 

 Manufacturer of the computer on which the NLM is installed. 
 Model of the computer on which the NLM is installed. 
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 Serial number of the computer on which the NLM is installed. 
 The license request file generated above (as an attachment). 

Vitech will reply with a CORELIC2.DAT file.  Place this file in the 
COREServer\HTTP\bin installation directory (C:\COREServer\HTTP\bin by 
default). 

Starting the CORE2net Server 
Once CORE2net has been licensed, the CORE2net Server must be started.  This is 
done from the CORE2net Monitor, which is accessible via the Utilities menu on 
the CORE Control Panel.  Access to the CORE2net Monitor is restricted to users 
with administration privileges.   
Note 
Because the CORE2net Server functions as a Web service, port 80 is used by default to 
communicate with client Web applications.  Other Web services such as the World Wide 
Web Publishing Service installed with Windows 2000 Server also use port 80 by default.  
Before the CORE2net Server is started, ensure that no other Web service is running on 
the computer also running the CORE Enterprise Server. 
If another Web service must run on the computer also running the CORE Enterprise 
Server, the default port number used by the CORE2net Server can be set via the HTTP 
Port field on the Settings tab of the CORE2net Monitor.  If this setting is changed, the URL 
used by client applications to access the CORE2net Server must contain the specified port 
number (e.g. http://192.16.11.10:5000 where 5000 is the new port number). 

To start the server, select the Start CORE2net Server command on the Server 
menu in the CORE2net Monitor (See Figure 7-1). 

 
Figure 7-1 CORE2net Monitor 
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Verify that the CORE2net Server has successfully started by opening the User 
Monitor, which is accessible via the Utilities menu on the CORE Control Panel.  
The CORE2net Server may take several seconds to start.  The User Monitor 
should display the HTTPCommServerUser account and the HTTPAppServerUser 
account within the Active Users list (see Figure 7-2).  

 
Figure 7-2 User Monitor 

Give Users Web Access Privilege  
After the CORE2net Server has been started successfully, all users with web 
access privileges can login to CORE2net.  To enable or disable a user’s web 
access privilege, toggle the privilege within the User Properties settings 
accessible from the User/Group Manager (See Figure 7-3). 
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Figure 7-3 User Properties 

Using CORE2net  
Login 

To access CORE2net, simply point either Microsoft Internet Explorer (version 4.0 
or later) or Netscape Navigator (version 4.75 or later) to the computer running the 
CORE Enterprise Server.  A user with the web access privilege enabled can then 
login using his/her existing CORE account name and password. 

Homepage 
A successful CORE2net login results with the homepage, which contains a listing 
of the available projects.  The project list is also available on the Projects menu, 
which is located at the top-left of the page below the CORE2net banner. 

Selecting a project from either the Projects menu or the list on the homepage sets 
the selected project as the target of all subsequent queries until a different project 
is selected.  The result of selecting a project is the list of queries that can be 
submitted against the selected project.  The name of the currently selected project 
is displayed at the top-right corner of the page below the CORE2net banner.  
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Queries 
The Queries provide dynamic access to information in the CORE database.  The 
Queries menu, which is located at the top-left corner of the page below the 
CORE2net banner, presents the list of available queries.  Selecting a query from 
the Queries menu provides real-time access to the CORE Enterprise Server 
database.   
Note 
Once a CORE2net Query is viewed in a Web browser, the browser will locally cache the 
page(s) viewed.  The browser will then display the locally cached page(s) for all 
subsequent requests to those pages.  The browser will not automatically submit a new 
request to the CORE2net Server to retrieve the most recent information once a page has 
been locally cached.  To retrieve the latest, updated information from the CORE 
Enterprise database, use the browser’s Refresh command to refresh the currently active 
page.   

Logout 
To logout of CORE2net, select the Logout link on the top-left corner of the 
CORE2net banner.  It is important for users to logout because CORE2net limits 
the number of concurrent user sessions based on the CORE2net license.  Logging 
out of CORE2net after the end of a session will decrement the concurrent users 
count allowing additional users to login.  CORE2net will automatically logout 
inactive sessions, which exceed the number of minutes specified by the Session 
Time Out setting accessible via the Settings pane on the CORE2net Monitor.
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A 
A. Installation Preparation 

The following appendix will detail how to perform a server and client installation 
of CORE Enterprise.  Readers using this appendix to perform server installations 
must have network and server administration experience.  Common 
administration tasks are not described in detail. 

The appendices are: 

• Appendix A – Server Installation Preparation, 

• Appendix B – Windows NT Install and Uninstall Procedures, 

• Appendix C – Windows 2000 Install and Uninstall Procedures, 

• Appendix D – Client Install and Uninstall Procedures, 

• Appendix E – Disaster Prevention and Recovery, and 

• Appendix F – Upgrading from Previous Versions. 

Server Installation Preparation 
Server Installation Worksheet 

Vitech technical staff will assist you in the server installation of CORE 
Enterprise.  Complete the following worksheet before your scheduled installation. 

The following is a CORE Enterprise pre-installation checklist worksheet.  This 
worksheet contains information that will help you identify what hardware and 
software need to be in place for CORE Enterprise installation.  This worksheet 
needs to be completed with the help of a Systems Administrator and/or a Network 
Administrator.  Please answer the questions and return them to Vitech at least 
three business days before the planned start of the installation. 
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Table A-1  CORE 4.0 Enterprise Installation Worksheet 
General 

Who is the CORE point of contact that will be working with Vitech during the installation?  
Who is the technical point of contact that will be working with Vitech during the installation?  

Network 
What type of network (e.g., Ethernet, Token Ring, etc.)?  
What is the speed of the network backbone, network interface cards, switches, hubs, etc. (e.g., 100 Mbps)?  

 
 
 

What other applications will run on this CORE Enterprise server and how many users do they serve? 

 
Server 

  What is the make of the server?  
  What is the model of the server?  
  How much RAM?  

How many CPUs & speed of each 
  Number of CPUs   CPU Speed 

How many physical hard drives (list a RAID array as a single disk) and partitions (e.g., C:, D:, etc.) 
  Disk 0 Partitions  
  Disk 1 Partitions  
  Disk 2 Partitions  
  Disk 3 Partitions  
  Disk 4 Partitions  

Partition information 
C: Size C: Free Space C: Paging File Size C: Format 
D: Size D: Free Space D: Paging File Size D: Format 
    
    
    
    

Operating system and server configuration 
What operating system is installed on the server (including patches)?  
Do you have a backup mechanism for this server (if yes, what is it)?  
Is a CD drive accessible?  
Is this server on the corporate LAN or an isolated network?  
Is TCP/IP configured on this server?  
What is this server’s IP address?  
Is this server listed by a Domain Name Server (if so, what is the symbolic IP name of this server)?  
If you are running Novell NetWare, are you running the Novix IP stack?  
Will clients connect to this Enterprise server remotely (if yes, by what method)?  
Is this server a Primary Domain Controller or Backup Domain Controller?  
Is the Schedule or Task Scheduler service running on this server?  

CORE Questions 
What licensing mechanism are you going to use (Network License Manager, node-locked, or floppy key)?  
How many total CORE Enterprise licenses are you planning to use?  
On which workstations do you intend to install CORE Enterprise client software?  
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CORE Users Worksheet 
During the installation, we will show you how to use CORE to create a user and 
apply the appropriate permissions.  In order for us to do this, you should compile 
a list of CORE user IDs (length of at least 3 characters) and passwords (length of 
at least 5 characters and not the same as the name).  You will want to retain a 
copy of the original IDs and passwords in case you need to recreate accounts in 
the future or on other servers so that permissions can be restored easily. You 
should also plan a hierarchy of groups and users and know which access control 
entities should receive the following privileges: System Administration, Project 
Creation, and Web Access.  For a definition of each of these privileges, consult 
the CORE Workstation Users Manual and Chapter 7 of this document.  A sample 
user worksheet is provided. 

Table A-2  CORE 4.0 User Worksheet 
Privileges 

User ID Password Full Name Description Groups 
System 
Admin 

Project 
Creation 

Web 
Access 
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B. Windows NT 
Installing CORE Enterprise Server 

Use this section as reference only.  Vitech technical staff will assist you in the 
CORE Enterprise Server installation. 

The following installation procedures must be performed at the machine on which 
CORE2net will be installed.  Do NOT attempt to install using Windows terminal 
services (e.g. PCAnywhere, Windows 2000 Terminal Services, etc…). 

Launch CORE 4.0 Installer 
Insert the CORE CD into a CD drive to which the server has access.  If the 
installer program does not launch automatically on the server, open the root 
directory of the CD in Windows Explorer and double-click SETUP.EXE. 

Select Install CORE Enterprise 4.0.  When prompted, select CORE Enterprise 
Server, and confirm by choosing Yes. 
Note 
The installer will prompt for the desired locations of four directories.  If possible, the CORE 
repository location and the CORE transaction logs location should be on a physical hard 
disk drive that is not used for Windows virtual memory.  This is very important for 
performance.  If two physical hard drives can be freed from Windows virtual memory, 
then the CORE repository location, and the CORE transaction logs location should also be 
on separate physical drives from each other.  Do not install any CORE Enterprise 
Server components in HPFS partitions. 

End-User License Agreement 
The installer will prompt to you to accept the terms of the license agreement.  If 
you accept this agreement, select yes.  If you do not accept this agreement, 
promptly return the CORE software and the accompanying items (including 
written materials and other containers) to the place where they were obtained. 
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Specify Root Location Program Files 
The installation process will prompt for the root location of the server program 
files.  The default is C:\COREServer.  It is recommended that these files be 
installed in the same partition as other application programs.  You can install 
these files in the same partition as Windows and/or Windows swap space.  The 
installer will create the following subdirectories in the specified location: 

 backup 
 bin 
 data 
 doc 
 HTTP 
 InstallAids 
 logs (initially empty) 
 scripts 
 sys 
 ualib 

Specify Location of CORE Repository 
For best performance, choose a physical hard disk drive that Windows does not 
use for virtual memory.  The default is C:\CORERepository. 

Specify Location of CORE Transaction Logs 
For best performance, choose a physical hard disk drive that Windows does not 
use for virtual memory.  For even better performance, choose a physical hard disk 
that is also separate from the CORE repository location selected above.  The 
default is C:\CORELogs. 

Specify Where Hot Backups Will Be Stored 
See Chapter 4, Backup and Recovery, for details of this feature.  The specified 
directory should have sufficient free space to hold five repository backups (a 
backup of an empty repository is over 13 MB).  The default is 
C:\COREBackups. 

Specify NetLDI Port Number 
This is the TCP/IP port number on which the CORE Enterprise Server listens for 
client requests. 
Note 
You must specify the same number during the installation of each client that will access 
this server.  This port number must not be used by any other TCP/IP services running on 
the server.  The default is 10075.  A line reflecting the specified value will automatically be 
added to the bottom of the SERVICES file.  This file is located by default at 
C:\WINNT\SYSTEM32\ DRIVERS\ETC\SERVICES.  You should search for other 
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SERVICES files on the server, which might be used in different configurations, and 
manually add the same line to each one.  The Windows registry value 
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\ 
DataBasePath points to the SERVICES file currently in use. 

Specify Database Update Ports 
These values are the UDP port numbers on which the CORE Enterprise Server 
will send database updates to the CORE Enterprise Clients. 
Note 
The default broadcast port number is 32051, and the default backchannel port number is 
32052.  These two values must be unique.  Additionally, each of these values must be 
different from the update port settings used within any other CORE Enterprise Server 
configuration on your network.  Two lines reflecting the specified values will automatically 
be added to the bottom of the system’s SERVICES file.  This file is located by default at 
C:\WINNT\SYSTEM32\ DRIVERS\ETC\SERVICES.  You should search for other 
SERVICES files on the server, which might be used in different configurations, and 
manually add the same lines to each one.  The Windows registry value 
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\ 
DataBasePath points to the SERVICES file currently in use. 

Finish Running CORE Installer 
Click the Install button to transfer all required files from the CD and install them 
on the server.  At the end of this process, click the Finish button to close the 
installer. 
Note 
The installer will automatically make the following changes to system environment 
variables: 

• A new variable GEMSTONE will point to the root CORE Enterprise Server 
program files directory. 

• A new variable CORERepository will point to the location of the CORE repository 
specified during the installation. 

• A new variable COREBackups will point to the location specified during 
installation for hot backups. 

• A new variable CORELogs will point to the location specified during the 
installation for the transaction logs. 

 
Note 
The installer will automatically add information to the Windows registry in the following locations: 

• HKEY_LOCAL_MACHINE \ SOFTWARE \ GemStone 
• HKEY_LOCAL_MACHINE \ SOFTWARE \ Vitech Corporation \ CORE2net Application 

Server 
• HKEY_LOCAL_MACHINE \ SOFTWARE \ Vitech Corporation \ CORE2net 

Communication Server 

 
Note 
The installer will automatically create shortcuts on the Start menu for all database 
maintenance scripts (.BAT files) in the scripts directory.  See Chapter 3, Administration 
Tools for the proper usage of these scripts. 
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Reboot 
At the end of the installer routine, it prompts you whether to reboot the server.  
Choose Yes or reboot the server yourself before continuing with the server 
configuration below.  (Make sure you log back in to the same account with 
administrative privileges). 

Customize SYSTEM.CONF 
The installer will place a SYSTEM.CONF file in the data subdirectory created 
above (e.g., C:\COREServer\data).  The following parameters at the end of this 
file should reference the CORE repository and transaction log locations specified 
above: 

 DBF_EXTENT_NAMES 
 STN_TRAN_LOG_DIRECTORIES 

Note 
If you need to modify this file (or are instructed to do so by Vitech), use a text editor such 
as the Windows Notepad, not a word processor such as Microsoft Word. 

The SYSTEM.CONF file also contains the following tuning parameters.  Great 
care should be taken in modifying them, as they significantly affect the operation 
and performance of the server.  Vitech must provide optimal settings for these 
parameters based on your server’s responsibilities, available RAM, and maximum 
number of concurrent CORE clients. 

 GEM_PRIVATE_PAGE_CACHE_KB 
 GEM_TEMPOBJ_CACHE_SIZE 
 SHR_PAGE_CACHE_SIZE_KB 
 STN_PRIVATE_PAGE_CACHE_KB 

Verify PATH Environment Variable 
1. Open Start > Settings > Control Panel > System > Environment. 
2. Verify that the installer appended %GEMSTONE%\bin to the PATH 

variable. 
3. Issue one of the following commands at a command prompt (e.g., in a 

DOS box) to verify that the system properly resolves the variable to the 
COREServer directory location: 

 path 
 echo %GEMSTONE% 
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Configure COREAdmin Account 
Create COREAdmin Account 

The COREAdmin account can be either a local account on the server machine or 
a domain account.  This account is only used by the CORE Enterprise Server 
itself, not by the CORE Enterprise users, so either is fine, but, to avoid confusion, 
do not create both a local account and a domain account.  If you perform these 
steps on a Windows NT Server, you will create a domain account.  Otherwise, 
you will create an account that can only be used on the local machine. 

1. Open Start > Programs > Administrative Tools > User Manager.  Select 
the User > New User menu command. 

2. Enter the username and password as follows: 
Username: COREAdmin 
Password: enterprise01 (required for installation) 

3. Turn off the User Must Change Password at Next Logon option and turn 
on Password Never Expires 

4. Click ADD to create the COREAdmin account 
5. In the User Properties dialog, click the Profile button. 
6. In the User Environment Profile dialog, fill in the Home Directory Local 

Path as follows: 
  C:\COREServer\logs 

(where C: is the drive selected for installation of the CORE Enterprise 
Server program files).  Click the OK button in both dialogs to apply 
the change. 

7. Click Close to dismiss the New User dialog. 
8. Select the Policies > User Rights menu command. 
9. Turn on the Show Advanced User Rights option. 
10. Select Log on as a service from the drop-down list of rights.  Click the 

Add button. 
11. In the Add Users and Groups dialog, select from the List Names From 

drop-down list either the name of the local machine if you created a local 
account or the domain name if you created a domain account. 

12. Click the Show Users button. 
13. Select COREAdmin in the list, click Add, and then click OK. 
14. Click OK to dismiss User Rights Policy dialog. 
15. Close the User Manager. 

Note 
If, after installation, you change the password of the COREAdmin account, you will have to 
manually change the password used by the COREStone and netldi51 services. 
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Set Directory Permissions 
Give the COREAdmin account full control of the created directories 
(COREServer, CORERepository, CORELogs, and COREBackups), as well as the 
WinNT directory, and their contents. 

The FAT file system does not support directory and file security, so the 
COREAdmin account already has full control of any directories that reside in 
FAT partitions.  Only perform the following steps for CORE Enterprise Server 
directories that reside in NTFS partitions. 

1. Open Start > Programs > Windows NT Explorer. 
2. Select each of the specified directories in turn and perform the following 

steps. 
3. Open File > Properties > Security > Permissions > Add. 

(If there is no Security tab on the Properties dialog, then the directory is 
on a FAT partition, and you do not need to set its permissions.) 

4. In the Add Users and Groups dialog, select from the List Names From 
drop-down list either the name of the local machine if you created a local 
account or the domain name if you created a domain account. 

5. Click the Show Users button, select COREAdmin and click Add. 
6. In the Type of Access drop-down list, select Full Control.  Click the OK 

button. 
7. Enable both Replace Permissions on Subdirectories and Replace 

Permissions on Existing Files. 
8. Click the OK buttons in both the Directory Permissions dialog and the 

Properties dialog. 
If prompted, click Yes to replace the security information. 

Finalize Server Installation 
Create CORE Enterprise Server Services 

Next, you must create the CORE Enterprise Server services themselves.  To 
accomplish this in Windows Explorer, select the COREServer\InstallAids 
directory (C:\COREServer\InstallAids by default), and double-click on the 
following two command files to execute them.  You can also execute them at a 
command prompt.  (The commands in these files reference the password file in 
the same directory and automatically add information to the Windows registry.) 

 CreateNetLDI.Bat 
 CreateStone.Bat 

Note 
To verify the successful creation of the CORE Enterprise Server services, open Start > 
Settings > Control Panel > Services. 
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Start Task Scheduler 
To schedule the automatic, periodic execution of database maintenance scripts, 
start the Task Scheduler service using Start > Settings > Control Panel > 
Services.  Set the Task Scheduler service to start automatically.  Then execute the 
following command in the InstallAids directory as above. 

 Schedule.Bat 
Note 
You can verify the successful scheduling of the database maintenance scripts by opening 
Start > Settings > Control Panel > Scheduled Tasks.  You should see 24 scheduled tasks. 

Start CORE Enterprise Server Services 
Start the COREStone and NetLDI services using Start > Programs > CORE 
Enterprise 4.0 Server > Start NetLDI and Start CORE Stone.  Clients will then be 
able to log in and begin work. 
Note 
You can verify the successful startup of the CORE Enterprise Server services by opening 
Start > Settings > Control Panel > Services. 

 
Note 
If either of the services cannot to start due to a login, try the corrective measures outlined 
in the Troubleshooting section near the end of Appendix B. 

Set Time Zone 
Set the new repository to the correct time zone.  By default, the time zone is 
Eastern Time (US).  To set the time zone: 

1. Open C:\COREServer\scripts\TimeZone.Scrpt 
(where C: is the drive selected for installation of the CORE Enterprise 
Server program files) in a text editor such as the Windows Notepad. 

2. Modify the parameters at the bottom according to the instructions in the 
file to reflect the server’s local time zone. 

3. Then locate TimeZone.Bat in the same directory and double-click on it. 
4. Check the output in COREServer\logs\TimeZone.Out to ensure that the 

script executed without error and that the change was successfully 
committed.  (The TimeZone.Bat script must be re-executed when restoring 
backup data into a clean repository.  See Chapter 4, Backup and Recovery 
for details.) 

Install Service Packs and Add-Ins 
If Vitech has supplied you with any CORE Enterprise Server service packs or 
add-ins, read their documentation carefully and install them at this time. 
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Network License Manager Installation 
Before installing the CORE Network License Manager, review the 
README.TXT file located in the corresponding directory on the CORE CD.  
This file contains the latest information, which may not be documented 
elsewhere. 

If you are already running Network License Manager 2.0 (application version) or 
4.3 (service version) on the CORE Enterprise Server machine, if you want to run 
the NLM on a separate machine, or if you will be using node-locked or floppy-key 
licenses rather than network licenses, then skip this section. 

Log on 
Log in to Windows NT as a user with administrative privileges. 

Launch CORE Installer 
Insert the CORE CD into a CD drive to which the server has access.  If the 
installer program does not launch automatically on the server, open the root 
directory of the CD in Windows Explorer and double-click SETUP.EXE. 

1. Select Install CORE Network License Manager. 
2. When prompted, select either NLM 4.3 (Service Version) or NLM 2.0 

(Non-Service Version), and confirm by choosing Yes. 
Note 
The advantage of installing NLM 2.0, which runs as an application, is that it provides a 
user interface whereby the operator can view the available license tokens and the licenses 
in use and can reclaim tokens.  However, a user must remain logged in at all times for 
NLM 2.0 to run.  The same administrative functions can be performed on NLM 4.3 via the 
NetTerm utility, and, in addition, NLM 4.3 runs as a service even when no user is logged 
in.  Therefore, NLM 4.3 is recommended. 

Specify Installation Directory and Transfer Files 
The recommended (default) directory is: C:\Program Files\Vitech 
Corporation\CORE NLM 43 for the service version and C:\Program Files\Vitech 
Corporation\CORE NLM 20 for the application version.  After you specify a 
directory, the installer will transfer files and finish. 
Note 
If you installed NLM 4.3, you can verify that the Network License Manager 4.3 service was 
created (Network License Manager 4.3.3) by opening Start > Settings > Control Panel > 
Services.  If the service is not listed, execute the following commands at a command 
prompt. 

• cd C:\Program Files\Vitech Corporation\CORE NLM 43 
(where “C:\Program Files\Vitech Corporation\CORE NLM 43” the path selected 
during installation) 

• nlmsvc43/install 

Close and reopen the Services control panel, and if the Network License Manager 
4.3 service still does not exist, contact Vitech Corporation technical support. 
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Generate License Request 
1. Open Start > Programs > CORE NLM 4.3 > Utilities > License Request.  

In the License Request Editor, 
2. Choose the File > Generate menu command. 
3. Enter your name or customer name in the User Information dialog.   
4. Enter the serial number found on the back of the CORE CD case and click 

on the OK button. 
5. Choose the File > Save As menu command in the License Request Editor 

and specify a file location. 
6. Send an email to support@vtcorp.com with the following information. 

 Manufacturer of the computer on which the NLM is installed. 
 Model of the computer on which the NLM is installed. 
 Serial number of the computer on which the NLM is installed. 
 The license request file generated above (as an attachment). 

Vitech will reply with a REGISTRY.DBX file.  Place this file in the CORE 
Network License Manager installation directory (e.g., C:\Program Files\Vitech 
Corporation\CORE NLM 43). 
Note 
Only run the License Request Editor once.  All CORE licenses including the 
REGISTRY.DBX file you receive from Vitech will be invalidated if you generate a 
subsequent license request on the same computer. 

Start Network License Manager 

CORE NLM 4.3 
1. Open Start > Settings > Control Panel > Services 
2. Start the Network License Manager 4.3 service. 

Note 
If the service fails to start, ensure that the REGISTRY.DBX file from Vitech Corporation 
was properly installed in the CORE NLM 43 directory as specified above. 

3. Open Start > Programs > CORE NLM 4.3 > NetTerm.  A new icon will 
appear in the “system tray” at the end of your Windows task bar. 

4. Double-click on this icon to display the NetTerm console. 
5. Ensure the upper window of the NetTerm console lists available tokens. 

Note 
If the NetTerm console is empty, ensure it is accessing the correct Network License 
Manager by choosing the Options > Network menu command.  In the Network Settings 
dialog, the NLM Address field should contain the IP address of the server running the 
Network License Manager (either a dotted decimal address or a symbolic name).  Test the 
validity of the address using the “ping” command at a command prompt.  The NLM Port 
should be 32000.  If you require assistance, first consult your network administrator. 

Note 
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If the previous remedy does not cause available tokens to be listed in the NetTerm 
console, try installing and running Network License Manager 2.0, copying the same 
REGISTRY.DBX file into its installation directory.  If the Network License Manager console 
lists the available tokens from the registry file then you have a NetTerm problem.  If the 
Network License Manager console is empty, then there is a problem with your 
REGISTRY.DBX file, and you should contact Vitech Corporation. 

CORE NLM 2.0 
1. Open Start > Programs > CORE NLM 2.0 > Network License Manager. 
2. Ensure that available tokens are listed in the upper window of the NLM 

console. 
Note 
If Network License Manager 2.0 fails to start, ensure that the REGISTRY.DBX file from 
Vitech Corporation was properly installed in the CORE NLM 20 directory as specified 
above. 

 
Note 
If the NLM console is empty, then there is a problem with your REGISTRY.DBX file, and 
you should contact Vitech Corporation. 

Troubleshooting 
If either of the CORE Enterprise Server services cannot start due to a login failure 
or if users attempting to log in to CORE Enterprise encounter an error specifying 
that the server is “unable to spawn a gem”, attempt the following corrective 
measures. 

1. Verify that only a single COREAdmin account exists rather than one local 
account and one domain-level account.  If there are two COREAdmin 
accounts, ensure that the COREStone and netldi51 services log in to the 
correct account. 

2. Use Start > Settings > Control Panel > Services.  Select each CORE 
Enterprise Server service in turn and click the Startup button. 

3. In the Service dialog, click the “…” button next to the This Account field. 
4. In the Add User dialog, before double-clicking on the COREAdmin 

account, select from the List Names From drop-down list either the name 
of the local machine if you want to use the local account or the domain 
name if you want to use the domain account. 

5. Verify that the local path of the COREAdmin account has been properly 
set as described above. 

6. Verify that the COREAdmin account has been given the right to log on as 
a service as described above, and, under Windows 2000, has been made a 
standard user. 

7. Verify that a netldi51 line has been appended to the SERVICES file, as 
described above, on both the client and the server. 
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8. Verify that the COREAdmin account has been given full control of all the 
created CORE Enterprise Server directories as well as the WinNT 
directory, as described above. 

9. Verify that the COREAdmin account has not been locked out due to 
previous login attempts with an invalid password. 

10. If you are installing CORE Enterprise Server on a primary domain 
controller, synchronize the domain and reboot the server machine.   

11. If you continue to experience login failures by the CORE Enterprise 
Server services, switch their passwords to the domain Administrator 
password (but leave COREAdmin as the login account). 

Visit http://www.vtcorp.com for more information, or contact Vitech technical 
support by email at support@vtcorp.com or by phone at 703-883-2270. 

Uninstalling CORE Enterprise 4.0 Server 
Note 
Failure to follow steps as written will cause software to remain on the system requiring 
another install before complete removal can occur. 

To remove a CORE Enterprise Server installation, follow these steps: 
1. You may wish to back up and archive the final state of the extent0.dbf file 

in the CORERepository directory. 
2. Stop the COREStone and NetLDI51 services using the menu commands 

for those purposes.  Ensure that all CORE Enterprise clients and the 
CORE2net server are logged out and shut down before stopping the 
services.  See chapter 7 for more information on CORE2net. 

3. Remove the services.  At a command prompt, execute the following two 
command lines: 

stone delete COREStone 
netldi delete 

4. At a command prompt, view the database maintenance script execution 
schedule using the “at” command.  Remove CORE Enterprise Server 
scripts from the schedule using “at <id> /delete”, where <id> is a task 
number obtained by using the “at” command alone.  You can remove all 
tasks from the schedule with “at /delete”.  If no tasks remain in the 
schedule after removing the CORE Enterprise Server scripts, you can stop 
the Schedule service in the Windows Services control panel. 

5. Remove the program files.  Go to Start > Settings > Control Panel > 
Add/Remove Programs and select CORE Enterprise 4.0 Server. 

6. All installed files should be automatically removed.  However, some data 
files and log files created after installation may have to be removed 
manually, along with the directories they were in. 

7. Go to Start > Settings > Control Panel > System > Environment.  
Remove “%GEMSTONE%\bin” from the PATH environment variable. 
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8. Remove the COREAdmin user account. 
9. Reboot the server. 
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Appendix 

C 
C. Windows 2000 
Installing CORE Enterprise Server 

Use this section as reference only.  Vitech technical staff will assist you in the 
CORE Enterprise Server installation. 

The following installation procedures must be performed at the machine on which 
CORE2net will be installed.  Do NOT attempt to install using Windows terminal 
services (e.g. PCAnywhere, Windows 2000 Terminal Services, etc…). 

Launch CORE 4.0 Installer 
Insert the CORE CD into a CD drive to which the server has access.  If the 
installer program does not launch automatically on the server, open the root 
directory of the CD in Windows Explorer and double-click SETUP.EXE. 

Select Install CORE Enterprise 4.0.  When prompted, select CORE Enterprise 
Server, and confirm by choosing Yes. 
Note 
The installer will prompt for the desired locations of four directories.  If possible, the CORE 
repository location and the CORE transaction logs location should be on a physical hard 
disk drive that is not used for Windows virtual memory.  This is very important for 
performance.  If two physical hard drives can be freed from Windows virtual memory, 
then the CORE repository location, and the CORE transaction logs location should also be 
on separate physical drives from each other.  Do not install any CORE Enterprise 
Server components in HPFS partitions. 

End-User License Agreement 
The installer will prompt to you to accept the terms of the license agreement.  If 
you accept this agreement, select yes.  If you do not accept this agreement, 
promptly return the CORE software and the accompanying items (including 
written materials and other containers) to the place where they were obtained. 
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Specify Root Location of Program Files 
The installation process will prompt for the root location of the server program 
files.  The default is C:\COREServer.  It is recommended that these files be 
installed in the same partition as other application programs.  You can install 
these files in the same partition as Windows and/or Windows swap space.  The 
installer will create the following subdirectories in the specified location: 

 backup 
 bin 
 data 
 doc 
 HTTP 
 InstallAids 
 logs (initially empty) 
 scripts 
 sys 
 ualib 

Specify Location of CORE Repository 
For best performance, choose a physical hard disk drive that Windows does not 
use for virtual memory.  The default is C:\CORERepository. 

Specify Location of CORE Transaction Logs 
For best performance, choose a physical hard disk drive that Windows does not 
use for virtual memory.  For even better performance, choose a physical hard disk 
that is also separate from the CORE repository location selected above.  The 
default is C:\CORELogs. 

Specify Where Hot Backups Will Be Stored 
See Chapter 4, Backup and Recovery, for details of this feature.  The specified 
directory should have sufficient free space to hold five repository backups (a 
backup of an empty repository is over 13 MB).  The default is 
C:\COREBackups. 

Specify NetLDI Port Number 
This is the TCP/IP port number on which the CORE Enterprise Server listens for 
client requests. 
Note 
You must specify the same number during the installation of each client that will access 
this server.  This port number must not be used by any other TCP/IP services running on 
the server.  The default is 10075.  A line reflecting the specified value will automatically be 
added to the bottom of the SERVICES file.  This file is located by default at 
C:\WINNT\SYSTEM32\ DRIVERS\ETC\SERVICES.  You should search for other 
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SERVICES files on the server, which might be used in different configurations, and 
manually add the same line to each one.  The Windows registry value 
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\ 
DataBasePath points to the SERVICES file currently in use. 

Specify Database Update Ports 
These values are the UDP port numbers on which the CORE Enterprise Server 
will send database updates to the CORE Enterprise Clients. 
Note 
The default broadcast port number is 32051, and the default backchannel port number is 
32052.  These two values must be unique.  Additionally, each of these values must be 
different from the update port settings used within any other CORE Enterprise Server 
configuration on your network.  Two lines reflecting the specified values will automatically 
be added to the bottom of the system’s SERVICES file.  This file is located by default at 
C:\WINNT\SYSTEM32\ DRIVERS\ETC\SERVICES.  You should search for other 
SERVICES files on the server, which might be used in different configurations, and 
manually add the same lines to each one.  The Windows registry value 
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\ 
DataBasePath points to the SERVICES file currently in use. 

Finish Running CORE Installer 
Click the Install button to transfer all required files from the CD and install them 
on the server.  At the end of this process, click the Finish button to close the 
installer. 
Note 
The installer will automatically make the following changes to system environment 
variables: 

• A new variable GEMSTONE will point to the root CORE Enterprise Server 
program files directory. 

• A new variable CORERepository will point to the location of the CORE repository 
specified during the installation. 

• A new variable COREBackups will point to the location specified during 
installation for hot backups. 

• A new variable CORELogs will point to the location specified during the 
installation for the transaction logs. 

 
Note 
The installer will automatically add information to the Windows registry in the following location: 

• HKEY_LOCAL_MACHINE \ SOFTWARE \ GemStone 
• HKEY_LOCAL_MACHINE \ SOFTWARE \ Vitech Corporation \ CORE2net Application 

Server 
• HKEY_LOCAL_MACHINE \ SOFTWARE \ Vitech Corporation \ CORE2net 

Communication Server 

 
Note 
The installer will automatically create shortcuts on the Start menu for all database 
maintenance scripts (.BAT files) in the scripts directory.  See Chapter 3, Administration 
Tools for the proper usage of these scripts. 
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Reboot 
At the end of the installer routine, it prompts you whether to reboot the server.  
Choose Yes or reboot the server yourself before continuing with the server 
configuration below.  (Make sure you log back in to the same account with 
administrative privileges). 

Customize SYSTEM.CONF 
The installer will place a SYSTEM.CONF file in the data subdirectory created 
above (e.g., C:\COREServer\data).  The following parameters at the end of this 
file should reference the CORE repository and transaction log locations specified 
above: 

 DBF_EXTENT_NAMES 
 STN_TRAN_LOG_DIRECTORIES 

Note 
If you need to modify this file (or are instructed to do so by Vitech), use a text editor such 
as the Windows Notepad, not a word processor such as Microsoft Word. 

The SYSTEM.CONF file also contains the following tuning parameters.  Great 
care should be taken in modifying them, as they significantly affect the operation 
and performance of the server.  Vitech must provide optimal settings for these 
parameters based on your server’s responsibilities, available RAM, and maximum 
number of concurrent CORE clients. 

 GEM_PRIVATE_PAGE_CACHE_KB 
 GEM_TEMPOBJ_CACHE_SIZE 
 SHR_PAGE_CACHE_SIZE_KB 
 STN_PRIVATE_PAGE_CACHE_KB 

Verify PATH Environment Variable 
1. Open Start > Settings > Control Panel > System > Advanced > 

Environment Variables on Windows 2000. 

2. Verify that the installer appended %GEMSTONE%\bin to the PATH 
variable. 

3. Issue one of the following commands at a command prompt (e.g., in a 
DOS box) to verify that the system properly resolves the variable to the 
COREServer directory location: 

 path 
 echo %GEMSTONE% 
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Configure COREAdmin Account 
Create COREAdmin account 

The COREAdmin account can be either a local account on the server machine or 
a domain account.  This account is only used by the CORE Enterprise Server 
itself, not by the CORE Enterprise users, so either is fine, but, to avoid confusion, 
do not create both a local account and a domain account.  If you perform these 
steps on a Windows 2000 Server, you will create a domain account.  Otherwise, 
you will create an account that can only be used on the local machine. 

1. Open Start > Settings > Control Panel > Administrative Tools > Active 
Directory Users & Computers. 

2. Select Users. 
3. Select the Action > New > User menu command. 
4. Enter the username and password as follows: 

Username: COREAdmin 
Password: enterprise01 (required for installation) 

5. Ensure the User must change password at next logon option is off and 
Password never expires option is on. 

6. Click the Next button to confirm your settings and then the Finish button 
to create the user. 

7. Select the COREAdmin account and select the Action > Properties 
command to view its properties. 

8. In the Properties dialog, select the Profile tab.  Fill in the Local path as 
follows: 

C:\COREServer\logs 
(where C: is the drive selected for installation of the CORE 
Enterprise Server program files). 

9. Select the Member of tab of the Properties dialog and confirm the 
COREAdmin account is a member of Domain Users. 

10. Click the OK button to dismiss the Properties dialog and then close the 
Active Directory Users and Computers window. 

11. From the Control Panel, open Administrative Tools > Local Security 
Policy > Local Policies > User Rights Assignment. 

12. Select Log on as a service and then choose the Action > Security menu 
command.  Click the Add button. 

13. In the Select Users or Groups dialog, select from the Look in drop-down 
list either the name of the local machine if you created a local account or 
the domain name if you created a domain account.  Select COREAdmin in 
the list, click Add, and click OK to apply the new right. 
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14. Click the OK button in the Local Security Policy Setting dialog and close 
the Local Security Settings window. 

Note 
If, after installation, you change the password of the COREAdmin account, you will have to 
manually change the password used by the COREStone and netldi51 services. 

Set Directory Permissions 
Give the COREAdmin account full control of the created directories 
(COREServer, CORERepository, CORELogs, and COREBackups), as well as the 
WinNT directory, and their contents. 

The FAT file system does not support directory and file security, so the 
COREAdmin account already has full control of any directories that reside in 
FAT partitions.  Only perform the following steps for CORE Enterprise Server 
directories that reside in NTFS partitions. 

1. Open Start > Programs > Accessories > Windows Explorer. 
2. Select each specified directory in turn and perform the following steps. 
3. Open File > Properties > Security > Advanced > Permissions > Add. 

(If there is no Security tab on the Properties dialog, then the directory is 
on a FAT partition, and you do not need to set its permissions.) 

4. In the Select Computer, User, or Group dialog, select from the Look in 
drop-down list either the name of the local machine if you created a local 
account or the domain name if you created a domain account. 

5. Select COREAdmin, and click the OK button. 
6. Select This folder, subfolders and files from the Apply onto list. 
7. Enable all the check boxes in the Permissions list, and click the OK 

buttons in the Permission Entry dialog and Access Control Settings dialog. 

Finalize Server Installation 
Create CORE Enterprise Server Services 

Next, you must create the CORE Enterprise Server services themselves.  To 
accomplish this in Windows Explorer, select the COREServer\InstallAids 
directory (C:\COREServer\InstallAids by default), and double-click on the 
following two command files to execute them.  You can also execute them at a 
command prompt.  (The commands in these files reference the password file in 
the same directory and automatically add information to the Windows registry.) 

 CreateNetLDI.Bat 
 CreateStone.Bat 

Note 
To verify the successful creation of the CORE Enterprise Server services, open Start > 
Settings > Control Panel > Administrative Tools > Services. 
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Start Task Scheduler 
To schedule the automatic, periodic execution of database maintenance scripts, 
start the Task Scheduler service using Start > Settings > Control Panel > 
Administrative Tools > Services.  Set the Task Scheduler service to start 
automatically.  Then execute the following command in the InstallAids directory 
as above. 

 Schedule.Bat 
Note 
You can verify the successful scheduling of the database maintenance scripts by opening 
Start > Settings > Control Panel > Scheduled Tasks.  You should see 24 scheduled tasks. 

Start CORE Enterprise Server Services 
Start the COREStone and NetLDI services using Start > Programs > CORE 
Enterprise 4.0 Server > Start NetLDI and Start CORE Stone.  Clients will then be 
able to log in and begin work. 
Note 
You can verify the successful startup of the CORE Enterprise Server services by opening 
Start > Settings > Control Panel > Administrative Tools > Services. 

 
Note 
If either of the services cannot to start due to a login, try the corrective measures outlined 
in the Troubleshooting section near the end of Appendix B. 

Set Time Zone 
Set the new repository to the correct time zone.  By default, the time zone is 
Eastern Time (US).  To set the time zone: 

1. Open C:\COREServer\scripts\TimeZone.Scrpt 
(where C: is the drive selected for installation of the CORE Enterprise 
Server program files) in a text editor such as the Windows Notepad. 

2. Modify the parameters at the bottom according to the instructions in the 
file to reflect the server’s local time zone. 

3. Then locate TimeZone.Bat in the same directory and double-click on it. 

4. Check the output in COREServer\logs\TimeZone.Out to ensure that the 
script executed without error and that the change was successfully 
committed.  (The TimeZone.Bat script must be re-executed when restoring 
backup data into a clean repository.  See Chapter 4, Backup and Recovery 
for details.) 

Install Service Packs and Add-Ins 
If Vitech has supplied you with any CORE Enterprise Server service packs or 
add-ins, read their documentation carefully and install them at this time. 
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Network License Manager Installation 
Before installing the CORE Network License Manager, review the 
README.TXT file located in the corresponding directory on the CORE CD.  
This file contains the latest information, which may not be documented 
elsewhere. 

If you are already running Network License Manager 2.0 (application version) or 
4.3 (service version) on the CORE Enterprise Server machine, if you want to run 
the NLM on a separate machine, or if you will be using node-locked or floppy-key 
licenses rather than network licenses, then skip this section. 

Log on. 
Log in to Windows 2000 as a user with administrative privileges. 

Launch CORE Installer 
Insert the CORE CD into a CD drive to which the server has access.  If the 
installer program does not launch automatically on the server, open the root 
directory of the CD in Windows Explorer and double-click SETUP.EXE. 

1. Select Install CORE Network License Manager. 

2. When prompted, select either NLM 4.3 (Service Version) or NLM 2.0 
(Non-Service Version), and confirm by choosing Yes. 

Note 
The advantage of installing NLM 2.0, which runs as an application, is that it provides a 
user interface whereby the operator can view the available license tokens and the licenses 
in use and can reclaim tokens.  However, a user must remain logged in at all times for 
NLM 2.0 to run.  The same administrative functions can be performed on NLM 4.3 via the 
NetTerm utility, and, in addition, NLM 4.3 runs as a service even when no user is logged 
in.  Therefore, NLM 4.3 is recommended. 

Specify Installation Directory and Transfer Files 
The recommended (default) directory is: C:\Program Files\Vitech 
Corporation\CORE NLM 43 for the service version and C:\Program Files\Vitech 
Corporation\CORE NLM 20 for the application version.  After you specify a 
directory, the installer will transfer files and finish. 
Note 
If you installed NLM 4.3, you can verify that the Network License Manager 4.3 service was 
created (Network License Manager 4.3.3) by opening Start > Settings > Control Panel > 
Administrative Tools > Services.  If the service is not listed, execute the following 
commands at a command prompt. 

• cd C:\Program Files\Vitech Corporation\CORE NLM 43 
(where “C:\Program Files\Vitech Corporation\CORE NLM 43” the path selected 
during installation) 

• nlmsvc43/install 
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Close and reopen the Services control panel, and if the Network License Manager 
4.3 service still does not exist, contact Vitech Corporation technical support. 

Generate License Request 
1. Open Start > Programs > CORE NLM 4.3 > Utilities > License Request 

in the License Request Editor. 

2. Choose the File > Generate Menu command. 

3. Enter your name or customer name in the User Information dialog.   

4. Enter the serial number found on the back of the CORE CD case and click 
on the OK button. 

5. Choose the File > Save As menu command in the License Request Editor 
and specify a file location. 

6. Send an email to support@vtcorp.com with the following information. 
 Manufacturer of the computer on which the NLM is installed. 
 Model of the computer on which the NLM is installed. 
 Serial number of the computer on which the NLM is installed. 
 The license request file generated above (as an attachment). 

Vitech will reply with a REGISTRY.DBX file.  Place this file in the CORE 
Network License Manager installation directory (e.g., C:\Program Files\Vitech 
Corporation\CORE NLM 43). 
Note 
Only run the License Request Editor once.  All CORE licenses including the 
REGISTRY.DBX file you receive from Vitech will be invalidated if you generate a 
subsequent license request on the same computer. 

Start Network License Manager 

CORE NLM 4.3 
1. Open Start > Settings > Control Panel > Administrative Tools > Services. 

2. Start the Network License Manager 4.3 service. 
Note 
If the service fails to start, ensure that the REGISTRY.DBX file from Vitech Corporation 
was properly installed in the CORE NLM 43 directory as specified above. 

3. Open Start > Programs > CORE NLM 4.3 > NetTerm.  A new icon will 
appear in the “system tray” at the end of your Windows task bar. 

4. Double-click on this icon to display the NetTerm console. 

5. Ensure that available tokens are listed in the upper window of the NetTerm 
console. 

Note 
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If the NetTerm console is empty, ensure it is accessing the correct Network License 
Manager by choosing the Options > Network menu command.  In the Network Settings 
dialog, the NLM Address field should contain the IP address of the server running the 
Network License Manager (either a dotted decimal address or a symbolic name).  Test the 
validity of the address using the “ping” command at a command prompt.  The NLM Port 
should be 32000.  If you require assistance, first consult your network administrator. 
 

Note 
If the previous remedy does not cause available tokens to be listed in the NetTerm 
console, try installing and running Network License Manager 2.0, copying the same 
REGISTRY.DBX file into its installation directory.  If the Network License Manager console 
lists the available tokens from the registry file then you have a NetTerm problem.  If the 
Network License Manager console is empty, then there is a problem with your 
REGISTRY.DBX file, and you should contact Vitech Corporation. 

CORE NLM 2.0 
1. Open Start > Programs > CORE NLM 2.0 > Network License Manager. 

2. Ensure that available tokens are listed in the upper window of the NLM 
console. 

Note 
If Network License Manager 2.0 fails to start, ensure that the REGISTRY.DBX file from 
Vitech Corporation was properly installed in the CORE NLM 20 directory as specified 
above. 
 

Note 
If the NLM console is empty, then there is a problem with your REGISTRY.DBX file, and 
you should contact Vitech Corporation. 

Troubleshooting 
If either of the CORE Enterprise Server services cannot start due to a login failure 
or if users attempting to log in to CORE Enterprise encounter an error specifying 
that the server is “unable to spawn a gem”, attempt the following corrective 
measures. 

1. Verify that only a single COREAdmin account exists rather than one local 
account and one domain-level account.  If there are two COREAdmin 
accounts, ensure that the COREStone and netldi51 services log in to the 
correct account. 

2. Use Start > Settings > Control Panel > Administrative Tools > Services. 

3. Select each CORE Enterprise Server service in turn and then open Action 
> Properties > Log On. 

4. Before double-clicking on the COREAdmin account, select from the Look 
in drop-down list either the name of the local machine if you want to use 
the local account or the domain name if you want to use the domain 
account. 
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5. Verify that the local path of the COREAdmin account has been properly 
set as described above. 

6. Verify that the COREAdmin account has been given the right to log on as 
a service as described above, and, under Windows 2000, has been made a 
standard user. 

7. Verify that a netldi51 line has been appended to the SERVICES file, as 
described above, on both the client and the server. 

8. Verify that the COREAdmin account has been given full control of all the 
created CORE Enterprise Server directories as well as the WinNT 
directory, as described above. 

9. Verify that the COREAdmin account has not been locked out due to 
previous login attempts with an invalid password. 

10. If you are installing CORE Enterprise Server on a primary domain 
controller, synchronize the domain and reboot the server machine.   

11. If you continue to experience login failures by the CORE Enterprise 
Server services, switch their passwords to the domain Administrator 
password (but leave COREAdmin as the login account). 

Visit http://www.vtcorp.com for more information, or contact Vitech technical 
support by email at support@vtcorp.com or by phone at 703-883-2270. 

Uninstalling CORE Enterprise 4.0 Server 
Note 
Failure to follow steps as written will cause software to remain on the system requiring 
another install before complete removal can occur. 

To remove a CORE Enterprise Server installation, follow these steps: 
1. You may wish to back up and archive the final state of the extent0.dbf file 

in the CORERepository directory. 
2. Stop the COREStone and NetLDI51 services using the menu commands 

for those purposes.  Ensure that all CORE Enterprise clients and the 
CORE2net server are logged out and shut down before stopping the 
services.  See chapter 7 for more information on CORE2net. 

3. Remove the services.  At a command prompt, execute the following two 
command lines: 

stone delete COREStone 
netldi delete 

4. At a command prompt, view the database maintenance script execution 
schedule using the “at” command.  Remove CORE Enterprise Server 
scripts from the schedule using “at <id> /delete”, where <id> is a task 
number obtained by using the “at” command alone.  You can remove all 
tasks from the schedule with “at /delete”.  If no tasks remain in the 
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schedule after removing the CORE Enterprise Server scripts, you can 
stop the Schedule service in the Windows Services control panel. 

5. Remove the program files.  Go to Start > Settings > Control Panel > 
Add/Remove Programs and select CORE Enterprise 4.0 Server. 

6. All installed files should be automatically removed.  However, some data 
files and log files created after installation may have to be removed 
manually, along with the directories they were in. 

7. Go to Start > Settings > Control Panel > System > Advanced > 
Environment Variables.  Remove “%GEMSTONE%\bin” from the PATH 
environment variable. 

8. Remove the COREAdmin user account. 
9. Reboot the server. 
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D. Client Installation 

Before installing CORE Enterprise 4.0 Client, review the README.TXT file 
located in the corresponding directory on the CORE CD.  This file contains the 
latest information, which may not be documented elsewhere. 

Preparation 
Client Hardware and Operating Systems Requirements: 

 Clients can run Windows 95, 98, NT, 2000, or Me. 
 Each client should have at least 32 MB RAM.  More will be required 

when accessing large amounts of data, especially under Windows 2000, 
which impose greater resource requirements. 
 Each client should be connected to the server via a LAN and be able to 

ping the server by name using TCP/IP. 

Installing CORE Enterprise Client 
Insert the first CORE installation diskette or CD into your drive and run 
SETUP.EXE from it.  You will be guided through the installation process.  No 
previous CORE installation is required to install CORE Enterprise.  The install 
program will ask for the directory (default is C:\Program Files\Vitech 
Corporation\CORE Enterprise 40 Client) in which CORE Enterprise should be 
installed.  DO NOT install CORE Enterprise into the same directory as any 
existing CORE installation. 

1. The installer will prompt to you to accept the terms of the license 
agreement.  If you accept this agreement, select yes.  If you do not accept 
this agreement, promptly return the CORE software and the 
accompanying items (including written materials and other containers) to 
the place where they were obtained. 

2. Next, the installer will prompt you for your name, company, and serial 
number.  Your CORE serial number is marked on the back of the CORE 
CD case. 
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3. Next, you will be prompted to provide the path where CORE Enterprise 
will be installed on the client machine.  The default is C:\Program 
Files\Vitech Corporation\CORE Enterprise 40 Client. 

4. Next, you will be asked for these two items:  
a) CORE Enterprise Server - this is the host name or IP address of the 

machine that will run the CORE Enterprise Server. 
b) NetLDI Port - this is the listening port on the CORE Enterprise 

Server. 
5. Next, you will be asked if the network license manager (NLM) will be 

used for licensing.  If you answer yes, you will then be prompted for three 
pieces of information. 

a) NLM Server - this is the host name or IP address of the NLM 
server. 
b) NLM Port - this is the listening port on the NLM server. 
c) NLM Reply Port - this is the port on the client machine. 

It is recommended that you use the default values provided for the Port 
and the ReplyPort.  If you have any questions concerning any of these 
values, please contact your network or systems administrator. 

The installation program will create a new program group with the title “CORE 
Enterprise 4.0”.  It contains a shortcut labeled “CORE Enterprise 4.0”.  To run 
CORE Enterprise Client using the configured server, simply choose this item 
from the Start menu. 

Uninstalling CORE Enterprise 4.0 Client 
To remove CORE Enterprise Client from your client machine 

1. Select Add/Remove Programs from the Windows Control Panel.   
2. Select CORE Enterprise 4.0 Client from the list of applications available 

to uninstall 
3. Click the Remove button.  This will remove all installed CORE Enterprise 

4.0 Client files from your machine. 
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E. Disaster Prevention & Recovery 
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There is no recovery log in CORE Enterprise as there is in CORE Workstation.  
All changes are immediately written to the server, so a crash on a client should 
not result in any loss of data, with the possible exception of the change in 
progress when the crash occurred. 

A CORE administrator with access to the server and to file backup tools should 
be assigned to regularly run the Hot Backup script on the server, following the 
instructions in Chapter 4, Backup and Recovery.  Hot backup files should be 
archived to tape.  In the event of repository corruption or a hard disk failure on 
the server, this will enable recovery to the state at the most recent hot backup. 

For additional protection, the CORE administrator can enable full transaction 
logging on the server as per the instructions in the following section.  This will 
enable recovery beyond the last hot backup to the very point where the failure 
occurred (so long as the transaction logs were not destroyed).  However, the cost 
of full transaction logging is reduced performance, and as repository corruption 
has never been observed, it is recommended that full transaction logging be left 
off. 

Turning-On Full Logging in CORE Enterprise Server 
1. Stop the CORE Stone using Start > Programs > CORE Enterprise 4.0 

Server > Stop CORE Stone. 

2. Using Notepad, edit the SYSTEM.CONF file located in the 
COREServer\Data directory. 

 Open the file. 
 Go to the end of the file using <Ctrl>+<End>. 
 Find the last instance of STN_TRAN_FULL_LOGGING = 

FALSE; 
 Change FALSE to TRUE 
 Save the file. 
 Exit Notepad. 
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3. Restart the CORE Stone using Start > Programs > CORE Enterprise 4.0 
Server > Start CORE Stone. 

Turning-Off Full Logging in CORE Enterprise Server 
1. Perform a hot backup of the database using Start > Programs > CORE 

Enterprise 4.0 Server > Hot Backup.  Verify that the operation completed 
successfully by looking at HotBackup.out in the logs directory.  See 
Chapter 4, Backup and Recovery. 

2. Stop the COREStone using Start > Programs > CORE Enterprise 4.0 
Server > Stop CORE Stone. 

3. Using Notepad, edit the SYSTEM.CONF file located in the 
COREServer\Data directory. 

 Open the file. 
 Go to the end of the file using <Ctrl>+<End>. 
 Find the last instance of STN_TRAN_FULL_LOGGING = TRUE; 
 Change TRUE to FALSE 
 Save the file. 
 Exit Notepad. 

4. Rename CORERepository\extent0.dbf to FullLogging.dbf.  Save the file 
until this procedure is complete and you have confirmed that the CORE 
Enterprise Server has been returned to operational status. 

5. Copy COREServer\Backup\extent0.dbf to the CORERepository directory. 

6. Locate the hot backup file created by step 1 in the COREBackups 
directory.  Its name is derived from the current date (in yymmdd format).  
Rename it to extent0.dbf. 

7. Run the script to restore data by double clicking on 
RestoreWithPartialLogging.bat file located in the COREServer\scripts 
directory.  Verify that the operation completed successfully by examining 
RestoreWithPartialLogging.out in the COREServer\logs directory.  All 
statements should have returned successful results. 
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Please read all the instructions in this section before beginning the upgrade 
process.  Details on how to perform each task may be found in the CORE 
Workstation User Reference Guide.  When exporting files, be sure to use the 
default names or names that identify the projects from which they were exported. 

Upgrading from Enterprise 3.1 to 4.0 
• Be sure to establish a time after which no further changes may be made to 

your CORE Enterprise 3.1 repository. 

• When it is certain that no users will be making further changes to the 
CORE Enterprise 3.1 repository, the CORE administrator should perform 
a full database export from every project in the repository. 

Note 
It is important to perform the exports from the Administrator account to ensure that all elements and 
attribute values are exported. 

• If schema customizations have been made to any projects in the CORE 
Enterprise 3.1 repository, the CORE administrator should also export the 
schemas from those projects. 

• If custom hierarchy diagram definitions or custom sort block definitions 
have been added to any projects in the CORE Enterprise repository, the 
CORE administrator should also export them from those projects using the 
Export Settings command. 

• To migrate your CORE users, user settings, and groups from your CORE 
Enterprise 3.1 repository to your 4.0 repository, the CORE administrator 
should also open the User Group Tool and export users and groups. The 
User Group Tool will prompt you for a directory in which to store a series 
of files, one for each user and group.   

• Archive a hot backup of the final state of your CORE Enterprise 3.1 
repository, should you wish to reinstall it for any reason.  You can find 
instructions for this process in the Chapter 4, Backup and Recovery. 
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Note 
Transaction logs generated by the CORE Enterprise 3.1 server are not compatible with the 
CORE Enterprise 4.0 server.  If any 3.1 logs exist in the CORELogs directory, the CORE 
Enterprise 4.0 server will simply overwrite the existing logs as necessary.  To avoid 
confusion, it is recommended that the existing 3.1 transaction logs be archived and 
removed from the CORELogs directory before upgrading the Enterprise Server software. 

• Unschedule the CORE Enterprise 3.1 automated maintenance scripts.  At 
a command prompt, view the maintenance script execution schedule using 
the “at | more” command.  Remove CORE Enterprise Server scripts from 
the schedule using “at <id> /delete”, where <id> is a task number 
obtained by using the “at | more” command.  If all the tasks in the 
schedule belong to CORE Enterprise, you can remove all tasks from the 
schedule with “at /delete”. 

• Run the CORE Enterprise 4.0 Server installer from the CORE 4.0 CD.  
The installer will automatically upgrade the existing CORE Enterprise 3.1 
Server file configuration.  During the upgrade process, the installer will 
prompt for the following information: 

 Database Update Ports – These values are the UDP port numbers on 
which the CORE Enterprise Server will send database updates to the 
CORE Enterprise Clients. 

Note 
These two values must be unique.  Additionally, each of these values must be different 
from the update port settings used within any other CORE Enterprise Server configuration 
on your network. 

 Install – Select the Install button to allow the installer to upgrade the 
CORE Enterprise server file configuration. 

Note 
During the upgrade process the following will occur: 

• The installer will attempt to stop the netldi51 and COREStone services if 
necessary.  If the installer is not able to stop the services, it will not be able to 
upgrade successfully.  In this case, verify that all CORE Enterprise clients are 
logged out of the server, and manually stop the services from the services 
section in the Windows control panel. 

• The installer will backup the existing extent0.dbf file to extent0.dbf.bak. 

 Reboot – Select yes to reboot the server. 

• After the server has rebooted, verify that the netldi51 and COREStone 
services have been successfully started.  If either of the services cannot 
start due to a login error, try the corrective measures outlined in the 
Troubleshooting section near the end of Appendix B. 

• Be sure to upgrade all CORE Enterprise clients that use the server from 
version 3.1 to version 4.0.  A CORE Enterprise 3.1 client will not be able 
to use the CORE Enterprise 4.0 server. 

• Once the CORE Enterprise 4.0 server is installed and operational, the 
CORE administrator should log in with a CORE Enterprise 4.0 client and 
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import the users and groups previously exported from CORE Enterprise 
3.1.  Open the User Group Tool and import the users and groups, choosing 
the directory where the ACF files were previously stored. 

• In the new CORE Enterprise 4.0 repository, the CORE administrator 
should create an empty project with the same name as each of the projects 
previously exported from CORE Enterprise 3.1. 

• Into each new project, the CORE administrator should import all the 
appropriate files: schema first, if applicable, then database and settings 
(hierarchy diagram and sort block definitions), if applicable. 

Note 
Database imports are significantly slower under CORE Enterprise than under CORE 
Workstation.  For best results, perform the imports via a CORE Enterprise Client installed 
on the same machine as a server, and perform the imports at an off-peak time. 

Upgrading from Enterprise 3.0 to 4.0 
• Be sure to establish a time after which no further changes may be made to 

your CORE Enterprise 3.0 repository. 

• When it is certain that no users will be making further changes to the 
CORE Enterprise 3.0 repository, the CORE administrator should perform 
a full database export from every project in the repository. 

Note 
It is important to perform the exports from the Administrator account to ensure that all elements and 
attribute values are exported. 

• If schema customizations have been made to any projects in the CORE 
Enterprise 3.0 repository, the CORE administrator should also export the 
schemas from those projects. 

• If custom hierarchy diagram definitions or custom sort block definitions 
have been added to any projects in the CORE Enterprise repository, the 
CORE administrator should also export them from those projects using the 
Export Settings command. 

• To migrate your CORE users, user settings, and groups from your CORE 
Enterprise 3.0 repository to your 4.0 repository, the CORE administrator 
should also open the User Group Tool and export users and groups. The 
User Group Tool will prompt you for a directory in which to store a series 
of files, one for each user and group.   

• Archive a hot backup of the final state of your CORE Enterprise 3.0 
repository, should you wish to reinstall it for any reason.  You can find 
instructions for this process in the Chapter 4, Backup and Recovery. 

• Unschedule the CORE Enterprise 3.1 automated maintenance scripts.  At 
a command prompt, view the maintenance script execution schedule using 
the “at | more” command.  Remove CORE Enterprise Server scripts from 
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the schedule using “at <id> /delete”, where <id> is a task number 
obtained by using the “at | more” command.  If all the tasks in the 
schedule belong to CORE Enterprise, you can remove all tasks from the 
schedule with “at /delete”. 

• Run the CORE Enterprise 4.0 Server installer from the CORE 4.0 CD.  
The installer will automatically upgrade the existing CORE Enterprise 3.0 
Server file configuration.  During the upgrade process, the installer will 
prompt for the following information: 

 Location of the CORE 4.0 repository – If the existing CORE 3.0 
Repository location is specified, the installer will backup the existing 
extent0.dbf file to extent0.dbf.bak.  For best performance, choose a 
physical hard disk drive that Windows does not use for virtual 
memory.  The default is C:\CORERepository. 

 Location of the CORE 4.0 transaction logs – For best performance, 
choose a physical hard disk drive that Windows does not use for 
virtual memory.  For even better performance, choose a physical hard 
disk that is also separate from the CORE repository location selected 
above.  The default is C:\CORELogs. 

Note 
Transaction logs generated by the CORE Enterprise 3.0 server are not compatible with the 
CORE Enterprise 4.0 server.  If the existing 3.0 CORELogs location is specified, the 
CORE Enterprise 4.0 server will simply overwrite any existing logs as necessary.  To avoid 
confusion, it is recommended that either a different location be specified or the existing 3.0 
transaction logs be archived and removed after the upgrade process has been 
successfully completed. 

 Database Update Ports – These values are the UDP port numbers on 
which the CORE Enterprise Server will send database updates to the 
CORE Enterprise Clients. 

Note 
These two values must be unique.  Additionally, each of these values must be different 
from the update port settings used within any other CORE Enterprise Server configuration 
on your network. 

 Install – Select the Install button to allow the installer to upgrade the 
CORE Enterprise server file configuration. 

Note 
During the upgrade process, the installer will attempt to stop the netldi51 and COREStone 
services if necessary.  If the installer is not able to stop the services, it will not be able to 
upgrade successfully.  In this case, verify that all CORE Enterprise clients are logged out 
of the server, and manually stop the services from the services section in the Windows 
control panel. 

 Reboot – Select yes to reboot the server. 

• After the server has rebooted, verify that the netldi51 and COREStone 
services have been successfully started.  If either of the services cannot 
start due to a login error, try the corrective measures outlined in the 
Troubleshooting section near the end of Appendix B. 
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• Be sure to upgrade all CORE Enterprise clients that use the server from 
version 3.0 to version 4.0.  A CORE Enterprise 3.0 client will not be able 
to use the CORE Enterprise 4.0 server. 

• Once the CORE Enterprise 4.0 server is installed and operational, the 
CORE administrator should log in with a CORE Enterprise 4.0 client and 
import the users and groups previously exported from CORE Enterprise 
3.0.  Open the User Group Tool and import the users and groups, choosing 
the directory where the ACF files were previously stored. 

• In the new CORE Enterprise 4.0 repository, the CORE administrator 
should create an empty project with the same name as each of the projects 
previously exported from CORE Enterprise 3.0. 

• Into each new project, the CORE administrator should import all the 
appropriate files: schema first, if applicable, then database and settings 
(hierarchy diagram and sort block definitions), if applicable. 

Note 
Database imports are significantly slower under CORE Enterprise than under CORE 
Workstation.  For best results, perform the imports via a CORE Enterprise Client installed 
on the same machine as a server, and perform the imports at an off-peak time. 

Upgrading from Enterprise 2.1 to 4.0 
• Be sure to establish a time after which no further changes may be made to 

your CORE Enterprise 2.1 repository. 

• When it is certain that no users will be making further changes to the 
CORE Enterprise 2.1 repository, the CORE administrator should perform 
a full database export from every project in the repository. 

Note 
It is important to perform the exports from the Administrator account to ensure that all elements and 
attribute values are exported. 

• If schema customizations have been made to any projects in the CORE 
Enterprise 2.1 repository, the CORE administrator should also export the 
schemas from those projects. 

• If custom hierarchy diagram definitions or custom sort block definitions 
have been added to any projects in the CORE Enterprise repository, the 
CORE administrator should also export them from those projects using the 
Export Settings command. 

• To migrate your CORE users, user settings, and groups from your CORE 
Enterprise 2.1 repository to your 4.0 repository, the CORE administrator 
should also open the User Group Tool and export users and groups. The 
User Group Tool will prompt you for a directory in which to store a series 
of files, one for each user and group.   
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• Archive a hot backup of the final state of your CORE Enterprise 2.1 
repository, should you wish to reinstall it for any reason.  You can find 
instructions for this process in the Chapter 4, Backup and Recovery. 

• Uninstall the CORE Enterprise 2.1 server.  Instructions for this process are 
the same as the instructions in this appendix for uninstalling CORE 
Enterprise 4.0 server. 

• Install CORE Enterprise 4.0 server according to the instructions in the 
Appendix B (Windows NT) or Appendix C (Windows 2000). 

• Be sure to upgrade all CORE Enterprise clients that use the server from 
version 2.1 to version 4.0.  A CORE Enterprise 2.1 client will not be able 
to use the CORE Enterprise 4.0 server. 

• Once the CORE Enterprise 4.0 server is installed and operational, the 
CORE administrator should log in with a CORE Enterprise 4.0 client and 
import the users and groups previously exported from CORE Enterprise 
2.1.  Open the User Group Tool and import the users and groups, choosing 
the directory where the ACF files were previously stored. 

• In the new CORE Enterprise 4.0 repository, the CORE administrator 
should create an empty project with the same name as each of the projects 
previously exported from CORE Enterprise 2.1. 

• Into each new project, the CORE administrator should import all the 
appropriate files: schema first, if applicable, then database and settings 
(hierarchy diagram and sort block definitions), if applicable. 

Note 
Database imports are significantly slower under CORE Enterprise than under CORE 
Workstation.  For best results, perform the imports via a CORE Enterprise Client installed 
on the same machine as a server, and perform the imports at an off-peak time. 
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