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CUSTOMER RESOURCE OPTIONS 

Supporting users throughout their entire journey of learning MBSE is central to Vitech’s mission. For 
users looking for additional resources outside of this document, please refer to the links below. 
Alternatively, all links may be found at www.vitechcorp.com/resources. 

 
Webinars 

Webinar archive with over 40 
hours of premium industry and 
tool-specific content. 

 
 

Screencasts 
Short videos to guide users 

through installation and usage of 
Vitech software.  

 
A Primer for Model-Based 

Systems Engineering 
Our free eBook and our most 
popular resource for new and 
experienced practitioners alike. 

 
Help Files 

Searchable online access to 
Vitech software help files. 

 
Technical Papers  

Library of technical and white 
papers for download, authored 
by Vitech systems engineers. 

 
MySupport 

Knowledge Base, Exclusive 
Webinars and Screencasts, 
Chat Support, Documents, 
Download Archive, etc.  

 
Our team has also created resources libraries customized for your experience level: 

All Resources  Advanced 
 

 
 

Beginner 
 

IT / Sys Admin 
 

 

 

Intermediate 
 

Student 

 

http://www.vitechcorp.com/resources/video_archive.php
http://www.vitechcorp.com/resources/screencasts.php
http://www.vitechcorp.com/resources/mbse.shtml
http://www.vitechcorp.com/resources/mbse.shtml
http://www.vitechcorp.com/resources/core/onlinehelp/desktop/Welcome.htm
http://www.vitechcorp.com/resources/technical_papers.php
http://www.vitechcorp.com/MySupport/support/Login.aspx?ReturnUrl=%2fMySupport%2fsupport%2fdefault.aspx
http://www.vitechcorp.com/resources/index.shtml
http://www.vitechcorp.com/resources/advanced.shtml
http://www.vitechcorp.com/resources/beginner.shtml
http://www.vitechcorp.com/resources/it_sysadmin.shtml
http://www.vitechcorp.com/resources/intermediate.shtml
http://www.vitechcorp.com/resources/student.shtml
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This guide describes the new schemas provided with CORE 9 and details how to migrate projects using 
previous schema versions using a migration script. Before conducting the migration process on your data 
it is important that this guide be read in its entirety. The data migration steps will change class names, 
relationship names, and attribute options.  
 
After reviewing this guide, contact Vitech Customer Support if you need additional assistance. Our Support 
Team is available Monday-Friday 9am-6pm Eastern with extended hours available by appointment. 
 
Email:  support@vitechcorp.com 
Phone:  540-951-3999 
 

OVERVIEW OF SCHEMA CHANGES IN CORE 9 
 
CORE 9 will support schemas from CORE 8. However, only CORE 9 schemas will provide full support of 
new views, diagrams, and features.   
 
 
 
 
 
 
 
 
Pages 3-7 of this document contain a complete list of all schema changes. For the most part, these changes 
reflect revisions, rather than deletions. Below is a chart that highlights where information is removed or 
changed in significant ways.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

Users should assess their project needs, their project lifecycle, and the changes present in the v90 
schemas to determine if, and when, to migrate their schemas. Projects nearing a major milestone or 
approaching conclusion should strongly consider remaining with their current schema. Vitech 
recommends that others consider moving to the v90 schemas to take advantage of the latest 
improvements in the MBSE language. 

mailto:support@vitechcorp.com
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Changes in both the Base and DoDAF schemas 
 

Class Detail of Change Impact to Data 

State/Mode 

Entities with type Mode 
transformed to Mode 
class. 

These entities will be moved to 
the Mode class. 

Entities with type State 
or nil transformed to 
State class. 

These entities will be moved to 
the State class. 

Type attribute is 
removed. 

The attribute is used to 
designate if entities become 
States or Modes in the migration 
and is obsolete after migration. 
No notice is made in conflict file. 

Mode 

If defined by relationship 
has a target, it is 
removed. 

Relation is removed. Notice is 
made in conflict file. 

If includes relationship 
has a target, it is 
removed. 

Relation is removed. Notice is 
made in conflict file. 

If included in relationship 
has a target, it is 
removed. 

Relation is removed. Notice is 
made in conflict file. 

State 
If includes relationship 
has a target, it is 
removed. 

Relation is removed. Notice is 
made in conflict file. 

Function 

For all targets of the 
defines relationship, if 
the type is Mode, then 
the relation is dropped. 

Relation is removed. No notice is 
made in conflict file. 

Risk 

RiskFactor attribute is 
renamed to riskRating.  
Existing values for this 
attribute are removed. 

Attribute information is removed.  
No notice is made in conflict file. 

 
 
 
 
Changes in the DoDAF schema only 

 

Class Detail of Change Impact to Data 

OperationalNode 
If joined to relationship 
has a target, it is 
removed. 

Relation is removed. Notice is 
made in conflict file. 

OperationalActivity 

For all targets of the 
defines relationship, if the 
type is Mode, then the 
relation is dropped. 

Relation is removed. No notice is 
made in conflict file. 
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USERS AND GROUPS 
 
Vitech recommends that you transfer your users and groups separately from your data, and that you do 
so prior to data migration.  To transfer your Users and Groups: 
 

1. Log into CORE 8 (or any prior version.) 
2. Click File > Export. 
3. In the Export Options dialog, in the Export drop-down, select Users & Groups. 
4. Click OK. 
5. Name the file and designated the location to which you would like to save the file. 
6. Click Save. 
7. Close CORE 8. 
8. Log in to CORE 9.  (You will need to log in using the default Administrator account.  The 

password is admin.) 
9. Click File > Import > CORE Data File. 
10. Navigate to the location where you saved the file in step 5.  Select that file and click Open. 
11. In the import wizard, click Next two times. 
12. Then click Import. 
13. CORE will alert you when the import is complete. 

 

DATA MIGRATION OVERVIEW 
 
Migration form CORE 8 to CORE 9 is a two-part process. The first part is to upgrade your CORE software 
from CORE 8 to 9. (Refer to the CORE 9 Installation Guide available on the downloads page of our website 
for detailed information regarding upgrading your software and your license.) The second part is to migrate 
project data to the v90 schema. While Vitech recommends that users update their software to CORE 9 as 
a soon as possible, there is no requirement to migrate project data immediately or at all. CORE 9 supports 
both the new v90 schema as well as the schemas in CORE 8. Note that if you choose not to upgrade your 
schema that you may not be able to take full advantage of the views, diagrams, and reports in CORE 9. 
 
 
 
 
 
 
Step-by-Step Instructions for Data Migration 
 
All steps of the database migration should be completed by a team member with administrator permissions. 
 
DO NOT uninstall CORE 8 until you have completed your data move, and have reviewed and approved the 
data. 
 

1. Export your project from CORE 8 using the File > Export command. Select Project Backup in 
XML format. 

2. If your project includes custom schema extensions, export your schema extensions separately 
using the File > Export command. Select Project Schema in XML format. 

3. Import your project into CORE 9 using the File > Import > CORE Data File command. In the Import 
Wizard, select to import it into a new project. (This will use the schema that was included with the 
export in step 1.) 

4. Import the appropriate schema migration file into the project you created using the File > Import > 
CORE Data File command.  (Both files referenced below are located in the \Program 
Files\Vitech\CORE 9\Data\Extensions folder. 

a. Select BaseSchemav80Migrator if you are using a Base schema. 
b. Select DoDAFv20Schemav80Migrator if you are using a DoDAF schema. 

5. Run the v80 to v90 Project Migrator v1.0 script using the Tools > Run Script command. 

If your data is in a schema version other than from CORE 8, please contact our Customer Support Team 
for assistance. 

http://www.vitechcorp.com/downloads
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6. At the conclusion of the migration script, CORE will alert you that the project has been migrated.  
Click OK. 

7. Then CORE will ask if you want to open the migration log file.  Click Yes and review the output.  
Save the file if desired. 

8. Click File > Import > CORE Data File. 
9. Select the \Program Files\Vitech\CORE 9\Data\Extensions folder. 
10. Select the Finalv80SchemaChanges.xml file and click Open. 
11. In the Import wizard, select to import it into your existing project. 
12. Export the project data. Note that in order to avoid some of the artifacts of the migration, using the 

File > Export > CORE Data File command and select Advanced Options. Select the following 
checkboxes: 

a. Database and the Stored Views sub-option 
b. Folders 
c. Filter Definitions 
d. Hierarchy Definitions 
e. Sort Definitions 

13. Create a new v90 project (using the Base or DoDAF v20 schema as appropriate) giving it a unique 
name. 

14. New projects in CORE 9 are created with a few elements to help you get started.  Because your 
project is already in progress, you’ll want to delete those.  Click Project > Erase > Database.  Click 
Yes to confirm. 

15. If you have custom schema extensions, import your schema file from step 2 into the new project. 
(Ensure that the schema extensions have imported correctly with the v90 schema by switching into 
database mode if not already there. If there are conflicts with the schema additions and v90 schema 
you need to correct these before you can continue.) 

16. Import your database from Step 12 into the new project. 
17. Copy the project properties from the original project to the new project. These include the 

description, guidance, base path, external graphics path, etc. from the project property sheet. 
18. In the Administrative tools, ensure that the project settings are correct. These would include 

versioning, audit logs, project permissions, initial element permissions, and maintaining merge 
history. 

19. In order to create a backup of your post-migration project, export your v90 project using the File> 
Export > CORE Data File command. Select Project Backup in XML format. 

20. Enjoy CORE 9! 
 
After migration, you will have two projects: your original version and the version with the new schema.  Take 
some time to examine them, and to examine the Conflict output (if there is one). If you wish to revert to the 
original version, you can simply delete the new version through Administrative Tools. (Be careful when 
deleting projects!  It is irreversible!) 
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COMPLETE LIST OF SCHEMA CHANGES IN V90 
 

General Changes Included in All Schemas (including Legacy Schemas) 

 New classes 
o Event (supporting state transition) 
o Transition (supporting state transition) 

 New relation pairs 
o contained by / contains 
o elicited by / elicits 
o encompassed by / encompasses 
o entered by / enters 
o exited by / exits 
o incorporated by / incorporates 
o reflected in / reflects 

 Class changes 
o Change Request Package 

 Added attribute action 
 Added target class Document 

to generated by relationship 
 Added target class section to 

impacts relationship 
o Document 

 Added attribute 
revisionNumber 

o Function 
 Added incorporated by 

relationship with target 
class State 

 Added reflected in 
relationship with target 
class Function 

 Added reflects 
relationship with target 
class Function 

 Add service relationship 
with target class 
Transition 

o Requirement 
 Added elicited by 

relationship with target 
class UseCase 

o State/Mode 
 Added PUID attribute 
 Added entered by 

relationship with target 
class Transition 

 Added exhibited by 
relationship with 
ImplementationUnit 

 Added exited by 
relationship with target 
class Transition 

 Added incorporates 
relationship with target 
class Function 

o UseCase 
 Added PUID attribute 
 Added elicits relationship 

with target class 
Requirement 

o VerificationRequirement 
 Added PUID attribute 
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Systems Engineering Schema Changes (also reflected in the DoDAF 2.0 Schema)

 New classes 
o Mode (to separate the concepts of 

states and modes) 

 Relationship changes 
o Changed wholeMultiplicity on the built 

from / built in relationship to an 
enumeration to support 
representation on block definition 
diagrams 

 Class changes 
o Component 

 Moved joined to relation from 
parent to Component 

o ConnectingUnit 
 Added includes relationship 

o Function 
 Removed defines relation 

o ImplementationUnit 
 Removed values attribute 

(now addressed by 
parameters) 

 Removed connected thru 
relationship 

 Removed joined thru 
relationship 

 Removed joined to 
relationship (moved to a 
subclass) 

 Added contains relationship 
with target class Mode 

 Added exhibits relationship 
with target class State 
(moved from a subclass) 

 Added generates relationship 
with target class Nexus 

o Interface 
 Added includes relationship 

with target class Interface 
 Added included in 

relationship with target class 
Interface 

 Set Parent-Child relationship 
to includes 

o Link 
 Added includes relationship 

with target class Link 
 Added included in 

relationship with target class 
Link 

 Set Parent-Child relationship 
to includes 

o Risk 
 Renamed consequences 

attribute to significance 
 Changed impact attribute 

 Renamed to 
consequence 

 Changed “Low” to “1 
– Minimal” 

 Changed “Medium” to 
“3 – Moderate” 

 Changed “High” to “4 
– Severe” 

 Added “2 – Minor” 

 Added “4 – 
Significant” 

 Changed likelihood attribute 
possible values 

 Changed “Low” to “1 
– Not Likely” 

 Changed “Medium” to 
“3 – Likely” 

 Changed “High” to “5 
– Near Certainty” 

 Added “2 – Low 
Likelihood” 

 Added “4 – High 
Likelihood” 

 Added mitigationCost 
attribute 

 Changed riskFactor attribute 

 Renamed to 
riskRating 

 Changed type to an 
enumeration 

 Added possible 
values to type 
attribute 

 Logistics 

 Requirements 

 Test and Evaluation 
o State/Mode 

 Renamed to State 
 Changed abbreviation to ST 
 Removed type attribute 
 Removed defined by 

relationship 
 Remove includes relationship 
 Removed included in 

relationship 
 Added decomposed 

relationship with target class 
State 
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 Added decomposed by 
relationship with target class 
State 

 Added encompassed by 
relationship with target class 
Mode 

 Facility changes 
o Document Management  

 Added Event 
 Added Mode 
 Added Transition 

o Essentials 
 Added State 

o Systems Engineering  
 Added Event 
 Added Mode 
 Added Transition 

o Verification Facility 
 Added Event 
 Added Mode 
 Added Transition 
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DoDAF 2.0 Schema Changes 

 New Classes 
o Classification 

 New Relationship pairs 
o classified by / classifies 

 Class changes 
o Capability 

 Added PUID attribute 
o ConnectingUnit 

 Added accessControl 
attribute 

 Added availability attribute 
 Added confidentiality 

attribute 
 Added integrity attribute 
 Added 

nonrepudiationConsumer 
attribute 

 Added 
nonrepudiationProducer 
attribute 

 Added includes relationship 
 Set Parent-Child relation to 

includes 
o Event 

 Added target class 
OperationalInformation to 
responsible for relationship 

o Needline 
 Added includes relationship 

with target class Needline 
 Added included in 

relationship with target class 
Needline 

 Set parent-child relation to 
includes 

o OperationalActivity 
 Removed defines 

relationship with target class 
State 

 Added incorporated by 
relationship with target class 
State 

 Added target class 
Transition to the services 
relationship 

o OperationalInformation 
 Added criticality attribute 
 Added target class Event to 

the assigned to relationship 
o Requirement 

 Added objective attribute 
 Added 

performanceParameterType 
attribute 

o State 
 Added target class 

OperationalActivity to the 
incorporates relationship 

o Transition 
 Added target class 

OperationalActivity to the 
serviced by relationship 

 Facility Changes 
o Architecture Facility 

 Added Classification 
 Added Event 
 Added Mode 
 Added Transition 





 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 

 

 

Vitech Corporation 

2270 Kraft Drive, Suite 1600 
Blacksburg, Virginia 24060 

540.951.3322  FAX: 540.951.8222 
Customer Support: support@vitechcorp.com 

www.vitechcorp.com 

mailto:support@vitechcorp.com
http://www.vitechcorp.com/

