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CUSTOMER RESOURCE OPTIONS
Supporting users throughout their entire journey of learning model-based systems engineering (MBSE) is
central to Vitech’s mission. For users looking for additional resources outside of this document, please refer
to the links below. Alternatively, all links may be found at www.vitechcorp.com/resources.

Webinars

Screencasts

A Primer for Model-Based
Systems Engineering

Webinar archive with over 40
hours of premium industry and
tool-specific content.

Short videos to guide users
through installation and usage of
Vitech software.

Our free eBook and our most
popular resource for new and
experienced practitioners alike.

Help Files

Technical Papers

Searchable online access to
Vitech software help files.

Library of technical and white
papers for download, authored
by Vitech systems engineers.

MySupport
Knowledge Base, Exclusive
Webinars and Screencasts, Chat
Support, Documents, Download
Archive, etc.

Our team has also created resources libraries customized for your experience level:
All Resources

Advanced

Beginner

IT / Sys Admin

Intermediate

Student
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GENESYS DOORS CONNECTOR GUIDE:
The DOORS Connector is a tool for exchanging requirements between GENESYS and IBM® DOORS®
through an OSLC interface. For GENESYS and DOORS to exchange data one-off setup and configuration
for the DOORS database has to be done. Then each project and the modules within the project have to be
configured. The data can then be exchanged as needed between the projects in GENESYS and DOORS.

DOORS WEB ACCESS & INTEROP SERVER SETUP AND CONFIGURATION
The GENESYS Connector communicates with DOORS using DOORS Web Access feature. DOORS Web
Access requires Redirector Service and Interop Server components configured to support the
communication. The Interop Server in particularly important to providing communication between
GENESYS and DOORS. The DOORS and IT administrators supporting your work group accomplish the
setup and configuration of DOORS Web services.
The standard DOORS Web Access installation and configuration should be performed, including the
modification of the core configuration file, festival.xml. This will allow the DOORS Web Server to
communicate with the broker, the license server and the DOORS database server.
The DOORS redirector service must be configured, including modification of the redirector configuration
file, doorsRedirector.properties. This will allow DOORS Web Access users to be able to use DOORS
URLs in the same way as Rational DOORS users. Users can then specify whether to open DOORS URLs
in a standard client or in the web client. The file doorsRedirector.properties will include changes similar
to those listed in the table below:
Before

After

<properties>
<comment>Configuration for DOORS Redirector.</comment>
<entry key="doors.url.prefix">doors://MY_DOORS_DATABASE_HOSTNAME:36677/</entry>
</properties>
<properties>
<comment>Configuration for DOORS Redirector.</comment>
<entry key="dwa.url.prefix">http://MY_DOORS_DATABASE_HOSTNAME:8080/dwa</entry>
<entry key="doors.enable">true</entry>
<entry key="doors.url.prefix">doors://MY_DOORS_DATABASE_HOSTNAME:36677/</entry>
<entry key="dwa.enable">true</entry>
</properties>

Two steps are required to ensure that the DOORS Web Access services are running correctly. The first
step ensures that the DOORS client is able to access the DOORS Server. The second step ensures that
the DOORS Web Access Server is accessible via HTTP. The DOORS Object Number is an important
attribute in the data exchange between DOORS and GENESYS. This attribute is not exposed using the
OSLC framework and so we need to run a service extension to make sure that it is available. The steps
below will help you confirm that this service has started:
1. Copy the file getNumber.inc from the GENESYS program folder C:\Program Files
(x86)\Vitech\GENESYS 4 Collaborative Edition\Extensions into the DOORS program folder
C:\Program Files (x86)\IBM\Rational\DOORS\9.5\lib\dxl\addins\services. The file getNumber.inc
contains the code:
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void getNumber(string par)
{
Buffer b = create
b = par
int i = contains(b, ',')
string oid = par[0 : i]
string pth = par[i +1 : ]
string num = null
int id = intOf(realOf(oid))
Module m = read(pth, true)
Object o = object(id, m)
num = number(o)
setDxlServiceResult num
}

2. Open the DOORS client, go to the Tools menu and select the Edit DXL… item to open the DXL Input
dialog box.
3. Copy the contents of the GetNumber Installer.txt file, found in C:\Program Files
(x86)\Vitech\GENESYS 4 Collaborative Edition\Extensions. Paste the code into the DXL Input dialog
box:
OSLCDXLService os = null
string err = null
string dxlCode = "#include <addins/services/getNumber.inc>\n"
err = addOrUpdateOSLCDXLService("getNumber", "Get Object Number
Service", dxlCode, "getNumber")
if (!null err)
{
print err
}
else
{
print "Installed Service\n"
}
4. Click Run
If the DXL Output pane contains "Installed Service" then the DOORS client access is okay.
Confirm the DOORS Web Server HTTP using a web browser to navigate to the URL access:
http://<servername>:8080/dwa
The server name, <servername>, and the port number, 8080 (by default), should be given to the user as
these will be used later in order to access the DOORS database from GENESYS.

PROJECT SETUP - SCHEMA EXTENSIONS
Once all the DOORS services have started for the GENESYS-DOORS Connector, configure the projects
that will use the connector. To ensure synchronization of the Requirements objects in DOORS project
modules with the corresponding Requirements entities in the GENESYS project, a set of attributes need to
added to both the DOORS project modules and associated GENESYS Class attributes.
In addition, a set of OSLC credentials need to be create in DOORS, which will be used by to access the
DOORS database.
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DOORS Schema Extension
For a DOORS module to be accessible from GENESYS, add several attributes to the DOORS module. The
table below lists the attributes to add to or modify in the DOORS Module.
Type

Attribute
Scope

GENESYS ID

String

Object

http://genesys.net/ns/rm/doors/attribute#genesysId

GENESYS
Name

String

Object

http://genesys.net/ns/rm/doors/attribute#genesysName

GENESYS
Class

String

Object

http://genesys.net/ns/rm/doors/attribute#genesysClass

Allocated
Component

String

Object

http://genesys.net/ns/rm/doors/attribute#allocatedComponent

Basis of

String

Object

http://genesys.net/ns/rm/doors/attribute#basisOf

Specifies

String

Object

http://genesys.net/ns/rm/doors/attribute#specifies

Attribute Name

Uniform Resource Identifier (URI)

Object Heading

http://jazz.net/ns/rm/doors/attribute#objectHeading

Object Text

http://jazz.net/ns/rm#primaryText

The attribute name column is descriptive text represented in the DOORS user interface. The URI column
is critical and provides the binding of the attributes between the two products. The steps used to add the
Attributes to DOORS are:
1. Open the DOORS project you wish to connect to.
2. Open the module to be connected to.
3. Select the Edit menu, and select the Attributes… item to open the Attributes Dialog box. Select the
New button and add the attributes listed to the module.
Once the DOORS module is configured as described above, close the DOORS Module, as we will no longer
need to access the DOORS module directly. All the data transfer / exchange will be initiated and controlled
from GENESYS.
Establish OSLC Credentials in DOORS:
In the DOORS client, select the File menu, open the OSLC item and select Local Keys… Click the Add
button and enter a set of OSLC credentials. The OSLC credentials that need to be entered are: Consumer
name; Consumer key; OAuth secret. The Consumer name is the DOORS Username. The OSLC
credentials are used in GENESYS to access the DOORS database from GENESYS.
GENESYS Schema Extension:
In order for GENESYS to be able to use the information stored in the attributes added to the DOORS
module, a schema extension is applied to the GENESYS project schema. Before making changes to the
GENESYS project, make a backup using the GENESYS Export feature. Once the project backup has been
created, import the schema extension by executing the following steps:
1. Open the GENESYS project.
2. Select Import from the GENESYS application menu.
3. Navigate to the file DOORS Connector Schema.gnsx located in the folder GENESYS 4
Collaborative Edition\Extensions\. Select “Next.”
4. Select the option “Import into Project” and choose the project to be modified. Select “Next.”
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5. The wizard will warn that you are importing data into a project that contains data. This is correct.
Select “Import” to start the import of the schema modification.
6. After the Import has completed you will now see the DOORS-related attributes created for the
Component, Function, Interface, Link, Requirement classes in the GENESYS project.
These steps extend the GENESYS project schema and the project can now interact with Requirements
from DOORS. Data transfer between DOORS and GENESYS is accomplished using Packages in
GENESYS. We need to create a Package in GENESYS, which will be the container for the Requirements
coming from DOORS. This is done by creating a Package entity under the Packages folder in the project
explorer. A Package should be created for each DOORS Module so that each module is contained inside
its’ own package for easier selection and viewing.
The DOORS and GENESYS projects are now ready to initiate the data exchange. The data exchange will
be controlled from GENESYS. There is no need to be logged into your DOORS module and it can be
closed.

IMPORTING REQUIREMENTS INTO GENESYS
This section describes how to import DOORS requirements into a GENESYS Project. To start this process,
select the Project tab in GENESYS and in the ribbon choose the Import ICON in the DOORS Section of the
Ribbon Bar.
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This will start the “DOORS Import Wizard.”
1. Use your DOORS login credentials (Username and Password) in the first part of the Import Wizard
dialog box. Use the Server Name, <servername>, port number, 8080 (by default) and the OSLC
Consumer Key and OAuth Secret to complete the remaining items in the dialog box.

2. Once you are logged in, the DOORS Import Wizard displays all the modules in your repository with
the schema extension configured for GENESYS. (If you do not see your module listed, check to
make sure the GENESYS schema extension has been applied to the module.) Select the DOORS
module you want to import into GENESYS and select “Next.”
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3. The wizard will now prompt you to choose a package within the GENESYS project accept the
information from DOORS. You can create a new package if needed. Select “Next.”

4. You are provided an option to structure the data using the “refined by” hierarchy. If selected, this
will create the parent/child relationships based upon the object hierarchy in the DOORS module
(the numbering of each object). Select “Next.”
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5. Finally, verify your selections and select “Import.”

A results dialog will display the results of the import with details of any conflicts encountered.
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When requirements are imported into GENESYS the first time, GENESYS generates a unique GENESYS
Name for each requirement by assigning a default name in the format of Requirement_###. Note that each
cell of a table in DOORS is considered a separate requirement.
The data is synchronized in GENESYS to allow for seamless syncing of information exchanged during
multiple import / export of information between the two toolsets. Additionally, in the event that the same
data is present in two or more DOORS module, the most recently accessed DOORS information will be
stored in GENESYS.
You can see a snapshot of the requirements that were imported from DOORS in GENESYS below. The
refines and refined by relationships are created based on the Object hierarchy organization in DOORS, if
that option was selected during import of the data.

EXPORTING REQUIREMENTS FROM GENESYS
The entities of the GENESYS repository to be transferred to DOORS need to be placed in a Package in
the GENESYS design repository. To accomplish this, complete the following steps:
1. Create a new Package in the Package folder.
2. With the Package selected, double click the packages relation to open the Edit Targets dialog box.
3. In the upper left pane, navigate to the folder which contains the entities to be transferred to DOORS;
then select the entities in the Possible Targets pane and Add them to the Targets pane.
4. When all of the target entities have been added, click on the Close button to dismiss the dialog box.
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A screenshot of Requirements packaged in GENESYS for export into DOORS is provided below.

Once the requirements have been packaged, we can initiate the export:
1. Open the Project tab in GENESYS ribbon and select “Export” command.
2. Use your DOORS and OSLC credentials (as described in the Import instructions) to validate your
access to the DOORS database.
3. Once the connection and access has been verified, you now see the GENESYS DOORS Export
Wizard with a list of the valid DOORS modules available. Choose the module to export into and
select “Next.”
If you do not see the module to be exported to, check in DOORS that the schema extensions have been
applied to the module (as detailed earlier in this document) and begin the export again.

Select the Package of interest created in the section above.

9

DOORS® Connector Guide

Verify your selections and select “Export.”

Once the export is completed, the wizard will show you a results dialog which will give you a summary of
the changes made and if there were any conflicts.
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The DOORS module will now have the requirements from GENESYS. The screen capture below shows a
section of the GENESYS attributes that were exchanged.
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